SourceTree suddenly insanely slow and crashes

Hello everyone,

First of all, I love SourceTree and I have been using it without any problems for about a year. However, a while ago, it just became insanely slow overnight. Now I can't use it as something as simple as viewing my working copy changes (with only one edited file) takes about 2 minutes. Every click I make takes ages to process and the interface is often bugged (for example it shows I'm 2 ahead while I have pushed everything).

I have tried some things including reinstalling, removing all repositories and re-adding them and removing all but one repo. I also browsed other questions posted here with similar problems and tried suggestions I found there, but nothing worked. My situation seems worse than any other question I've found.

I am using system Git and have a high-end laptop. Please ask if you need more info/specs.

Any help is appreciated!

12 answers

Try out some operations from the Git command line. That will narrow down whether it is a Sourcetree-specific issue, or if Sourcetree is suffering from a problem in your Git installation.

I've been having issues too and it started right after I updated.

Command line Git just works normally. I also tried installing another GUI (Github for Windows) and that also works normally. It's just SourceTree that's slower. Might be a recent update indeed.

have you resolved this issue? I have the same issue. I am on 1.6.11

I hope a new update comes out to fix this. I can barely work on my project and its been making it difficult.

Any chance your antivirus is slowing things down? Try adding an exception for the SourceTree folder and the folder where you keep your clone(s).

I have noticed issues as well. Most recently, after leaving sourcetree open for an entire weekend, I returned to find it appearing to lock up after almost every click. At one point, sourcetree hung while a context menu was open and for several minutes it was hovering over all my other windows as I worked on other things. I did notice that in this situation, the memory usage steadily climbed up to 1.2GB before the UI became responsive again. After I restarted sourcetree, the memory usage was back down under 100k and performance had returned to normal. Aside from the occasional freak-out, performance has been great.

To respond to your questions. I have tried turning off my antivirus and firewall, I have reinstalled and restarted SourceTree (and Git) multiple times. None of that helped unfortunately.

I'm having similar trouble (on Win7 with 1.6.11). In my case, I have three bookmarks (repos) that I switch between frequently. One of them is slightly large (~10000 files, ~400 folders, ~120MB), although that still seems pretty small to me. :) Anyway, most times when I switch to the large bookmark, the UI freezes. Maybe one out of 5 times this happens, if I wait long enough (more than 5 minutes), it will finally display properly, but if I click anything else, it dies again. I did watch the TaskManager resources while this was happening: For the repos that work, RAM was between ~60MB and ~150MB, with minimal CPU. When on this crashing repo, the RAM started rocketing upwards, climbing to ~1.2 or 1.4 GB with CPU around 30%. I'm evaluating using Stash for my small group's SCM tool, so I need a reliable, simple client tool and I'm leaning towards Sourcetree, but this performance trouble is terrible. I downgraded to an older copy of Sourcetree I had (1.5.2) and it works fine now. I'm not sure what I'm missing with that older version, but it definitely fixed the freezing/crashing problem for me. Here's hoping Atlassian will chime in with some info about how to fix this with the latest version. Thanks! Justin

Hi Justin. Your answer gave me a thought about what the problem MIGHT be, though it's just a guess. I am using Sourcetree with system Git. Git for Windows is always a couple of versions the actual most recent version (for example the current latest version is 2.2.0 while Windows is still on 1.9.4, which is 2 months old). Meanwhile my Sourcetree is updated to the latest version. Could it possibly be that Sourcetree expects the latest Git version and gets slow because it doesn't exactly get what it wants? That could explain why older Sourcetree versions still work fine. Again, I don't know much about the inner workings of Git and Sourcetree so this is just speculation. I might try going back to an older version of Sourcetree to see if that helps.

Hi I have run into this as well with some small repositories. I uninstalled and then installed 1.6.8.0 and all is good with it again. Thanks James. OS: Windows 8.1 x64

I took a look at a running copy of 1.6.12 with ProcMon. Basically every click on the UI causes it to open the .git and .hg files for every project in your bookmarks, even if the bookmark pane is hidden. Removing old projects and restarting seems like it might've helped some. Also, if you have A/V installed you might want to add exceptions for all your code folders.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

649 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you