Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree on Windows is not prompting for password when connecting to git repository.

I have several private repositories on my own server that I connect to from Windows machines with password authentication. Today, I cannot connect to them because SourceTree is not showing the Username/Password dialog anymore. I can connect when using the system git from the command line and when using the git bash that pops up when pressing the "Terminal" button in SourceTree, so I know everything is fine on my git server. I can also connect from OSX machines using SourceTree, but they use SSH authentication instead of password authentication.

I ran Askpass.exe separately and it shows the dialog correctly and returns the password, but it doesn't show when it should in SourceTree.

 

I downgraded SourceTree to 1.6.14 but it doesn't show the password dialog now, either.

 

I also tried setting up an SSH key with SourceTree's Putty, but that didn't work, either.

 

Any ideas?

3 answers

Have same issue on Win 7 & SourceTree 1.8.3. It does not ask for password and fails immediately with "FATAL ERROR: Server unexpectedly closed network connection". Git from command line works and asks for password. Removal of credentials did not help.

The only thing that worked for me was navigating to C:\Users\%USERNAME%\AppData\Local\Atlassian\SourceTree and removing the passwd file.

Thanks! This is the only thing that worked for me....apparently this is a two-year old bug

Bug is still very much alive. You saved me after an hour of googling and reinstalling. Jeff Andrew, there was nothing in `Tools > Options > Authentication` except my Atlassian login, not my ssh login for my private server. This stinks!

0 votes
Jeff Thomas Atlassian Team Nov 03, 2015

Hi Andrew,

You may want to try clearing the credentials out of SourceTree if they are cached there. This can be done under Tools > Options > Authentication

 

Tools > Options > Authentication

I had to delete the account and re-enter username password. Before it worked. Simply updating password did not work

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Sourcetree

[dev team] Sourcetree for Windows 2019 Preview - Dark Theme

Hi folks, While the full post is over on our blog I'd like to share the dark theme we've got planned for 2019 here directly as well to keep the discussion going.  The ...

3,230 views 19 18
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you