SourceTree not working on Mac OS X Mountain Lion

Hello,

I have installed SourceTree on Mountain Lion, once over the AppStore and once as direct download. The App always starts without any problems but I cannot get a connection to a svn server. I enter the Server URL and hit enter, and I just get the rotating waiting sign. I can check out the repository over git svn in the console and everything works.

I have already installed the Command Line Tools over Xcode and the py2.7-hgsubversion package with macports.

Any Idea why sourcetree still does not work?

Thanks a lot. Bernd

1 answer

Unfortunately Mountain Lion removed both Subversion and the python bindings by default. I've created 2 KB articles (one for git-svn, one for hgsubversion) which worked for me from a clean Mountain Lion install:

Hgsubversion on Mountain Lion

Git-svn on Mountain Lion

It sounds like you may have already followed these instructions but I've included them for completeness.

If, after setting this up, you get the spinner, it's usually this: Perpetual spinner when trying to clone Subversion

Thanks for your help! I went through all the tutorials you posted. It's still not working, but I think i'm getting closer. Problem is still the same.

My standart python Version is 2.6, but I have 2.7 installed . Does Sourcetree call 2.7 explicitly or does it just call python?

Concerning the Hgsubversion bindings: As I said, I have already installed them with macports. I tried to install them with Homebrew again, but I get some arrows when Homebrew detects the macports installation. But it should also work with macports, if I changed the command to :

sudo sh -c 'echo /opt/local/lib/libpython2.7.dylib > /Library/Python/2.7/site-packages/subversion.pth'

But I'm not sure about that part.

How can I checkout in python wether the bindings are installed?

Thanks a lot for your help.

SourceTree doesn't call Python itself, but the hg script does. Mercurial does still work with Python 2.6, because that's the default version on Mac OS X 10.6, but it's sub-optimal because the precompiled Mercurial is based on 2.7, so using 2.6 will require recompilation. Worse, any bindings you've installed for Python 2.7 won't be usable. Python 2.7 is the default version for Mac OS 10.7 and 10.8, so I assume you've changed this for some other reason. Is there any way you can revert to the system default Python in general, and just specify Python 2.6 when you need it?

If not, you'll probably need to install the Python 2.6 SVN bindings separately, which could get tricky if Macports is wanting to use the latest. I'm sure it's possible, but if you can avoid it it's probably better.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

676 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you