Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

SourceTree not showing the diff just says 'select a file to view the diff'

Phill Ashworth November 30, 2022

When I select a modified file the diff isn't shown in the adjacent pane, it just says "select a file to view the diff" even though I have selected a file. Some files correctly show the diff but others don't.
I'm on the latest 3.4.10 version.
Any ideas how to fix this?


2 answers

1 vote
Philippe Cloutier March 14, 2023

Good question. My colleague and I are evaluating Sourcetree 3.4.12 and both of our installs are affected. Sourcetree is at its defaults, using the embedded Mercurial 4.8.1, which surprisingly appears to be the latest one available. Trying to use a system Mercurial seems to fail, although there is no error.

We first thought all files were affected, but my colleague noticed the side diff works for .hgtags.

Philippe Cloutier March 14, 2023

This is a 3.4.10 regression. My colleague and I both went to 3.4.9 and that fixed it for us.

Like # people like this
joedf July 13, 2023

Downgrading from 3.4.14 to 3.4.9 worked for me. Thanks!

Git diffs worked fine, but not Mercurial diffs...

0 votes
MrJJ December 2, 2022

I also suffer from this "feature" and so far found no fix.  I also installed it on another laptop and the diff is not working there either.   both win 10.  so maybe it's my repro.  

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events