Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree not able to detect the Git installed

Below is configuration and details
OS – Windows 7 64 bit
Git version – 2.18.0 64 bit
Source Tree – 2.6.10
 Error – Source Tree keep pooping up popup that , it not able to detect the Git on system ,tried all three option, the option Browse to the location of Git on your system (if we missed it) , not opening anything , i mean no browse popup come to select path , just after some time again the same popup come up .
I tried to download an embedded version option too through this popup  but that is also not working.
 Tried all three option in this popup above but still it not able to detect the git. My system path variable is set properly ,
Any help suggestion ?

3 answers

SourceTree Git not working in Windows Solution found just follow this:

Open SourceTree >> Tools >> Options >> Git
by default "Embeded" button is clicked change this to "System" it will now on take system installed git path which is windows installed git path.

Now Restart the Source Tree.
Note: I have windows 10 64bit & i have added git path in environment variable "C:\Program Files\Git" not sure its needed or not.

See Image attached:git-source-tree.png

I have the same problem. I used git V2.17 and also tried 2.23.0 for Windows 64bit versions. I then also tried to enable Mercurial; same problem.

BUT when I start SourceTree as an administrator on Windows (right click + Run as Administrator) it works. So it seems to be a permission problem but in the logs there is nothing that would shed some light on it. I checked the git installation folder and all Windows users have read and execute permission to that folder. So also that should be ok. And in PowerShell as a normal user git works just fine and also is in the PATH.

I used SourceTree and git since many months now on this Windows machine and never had a problem.

Any ideas how to get more detailed logs that could tell us what could cause this problem?

0 votes
minnsey Atlassian Team Aug 28, 2018

Hi

Sourcetree will try to find and use an existing Git installation rather than download and install its own local copy.

It does this by checking the PATH, looking in some standard locations, e.g. c:\program files (x86)\Git or asking the OS to find it.

If it finds a git.exe through any of those methods it tries to run

>git version 

and parsing the output, if it matches a supported version it will configure itself to use that Git installation.

If it can't find a git.exe it will prompt you to try and look for it.

Where is your Git installed?

It sounds like Sourcetree might be finding the installation bur for some reason the git version call is failing.

Is there anything in the %localappdata%/Atlassian/Sourcetree/sourcetree.log showing errors when trying to run git version ?

My git version is 2.20.1.vfs.1.1.104.g2ab7360

I have 

C:\Program Files\Git LFS
C:\Program Files\Git\cmd
C:\Program Files\GVFS

all git commands work find. I still get the prompt when launching SourceTree, but clicking on "Browse to the location of Git on your system (if we missed it)" does nothing, it just shows the "Git not found" dialog again ...

Like james-lo-apricot likes this

P.S. I'm using VFS For Git 1.0.19130.1 from https://github.com/microsoft/VFSForGit/releases

Mike Corsaro Atlassian Team Jun 11, 2019

Hello! We don't currently support the latest version VFS but we're hoping to release the 3.2 update within a few weeks with support. Sorry about that!

 

It's a hack/not a great work around, but if you build your own version and change the version string to gvfs rather than vfs then it will work.

Like Steven Hand likes this

FYI, I'm using VFS for Git as well. (git version 2.20.1.vfs.1.1.104.g2ab7360)

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

5,733 views 4 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you