SourceTree login issue on macOS 10.12 stating Password Required

I've updated to macOS Sierra and I'm using SourceTree 2.3.1 (69). I've got all my repos setup to use SSH. I'm getting the dialog Password Required For user git on host bitbucket.org. There is a text entry field and the "Store Password in Keychain checkmark.

1) Why am I getting this with SSH?

2) I have tried adding my Atlassian ID password and giving permission to access the Keychain but it just loops as if the password in invalid.

3) all these repos were working before updating to macOS Sierra. However, I did have some issues with the change form the Bitbucket credentials to the Atlassian ID using SourceTree but they seemed to be sorted out.

8 answers

1 accepted

This widget could not be displayed.

I got it to work again using the command line first. Try to fetch your repo using the Terminal (while it's still setup to use SSH). In my case I was prompted to enter the password for my ssh key file on the Terminal, which makes more sense than to enter your bitbucket/Atlassian password "for user git" in the GUI. After doing that fetching and pulling using SourceTree did work again as expected.

That did fix the issues. I hadn't thought I would need to unlock the SSH key after updating macOS.

This widget could not be displayed.

Open a terminal and type "ssh-add", when prompted type in the password for your SSH RSA key.

To verify if you have an SSH RSA key in your profile, type "ssh-add -L".  After upgrading to Sierra it will say something like "The agent has no identities".

It works perfectly. thank you.

I didn't need to do anything more than this. Thanks! (When I switched back to SourceTree and responded to the failed pull dialog it instantly was in contact with the remote and listing new changes to be pulled.)

Thanks Matt, this worked for me.  I'm using MacOS Sierra, 10.12.6  and SourceTree Version 2.6.3.

Doesn't seem to work for the macOS High Sierra update.

Thx Matt ;) it worked for me on High Sierra

This widget could not be displayed.

Same problem for me - I got it working by answering the password question with the passphrase for my key, rather than the password for the server (that part seems like a bug).  That makes it happy for a single operation. Doing ssh-add as described above makes it stick.

Easiest fix, solved the issue for me. Thank you!

Hey, I'm having a similar issue - from memory I have made my SSH pass phrase the same as my password however I think maybe if I can change my pass phrase I can try it.

Can you tell me how I can access my SSH keyphrase?

This widget could not be displayed.

I was able to get SourceTree working again by changing to HTTPS. I tried creating and installing a new public key in Bitbucket, but that didn't help with SSH.

I also noticed that LFS is failing with SourceTree getting all kinds of errors. I updated my local Git LFS to 1.4.1 and chose that in SourceTree and that seemed to solve that problem. I was using the embedded Git LFS before.

I'd rather be using SSH, but at least things are working again for now.

This widget could not be displayed.

Same annoying problem for me.  I installed Git Kraken and it worked perfectly, so it seems to be a problem with Source Tree.  It looks like even though I am using SSH- its trying for some strange reason to access my keychain password.  It looks like a bug. 

 

I tried putting in my bitbucket password and got this error. 

 

(internetKeychainItemForServer:withUsername:path:port:protocol:) - The specified item could not be found in the keychain.
User cancelled password prompt.2016-10-14 13:32:13.889 SourceTreeLogin[13319:776438] User cancelled password prompt.
Permission denied (publickey).

 

 

I managed to get it working by: 

  1. Manually pushing a change via command line and entering in the password for my RSA key when prompted.  

    I wonder if the password prompt is just not asking the correct question. I think the password prompt should probably mean to ask for the SSH password not the Bitbucket one.  It could be a bad usability thing causing the bug. There are loads of reports of this issue - so hopefully it will help others. 

 

This widget could not be displayed.

Did you find an answer to this?

This widget could not be displayed.

I recently started getting the prompt to enter the password when interacting with the server, and it turns out the password it wanted was not my actual server account password but my SSH key password. (I am using SSH and not HTTPS.)

The "Password Required" dialog text makes it sound like it wants the server password.

This widget could not be displayed.

After looking at this thread and reading  Adding Bitbucket SSH Key,

1)  Delete/Backup old SSH key

2) Create new SSH key  (follow  Adding Bitbucket SSH Key,) with a passphrase

3) Add SSH key to BitBucket

4) When prompted SourceTree for keychain access, entered my passphrase.

NOTE: I think this issue was a from the MacOS security upgrades that were for a root access issue --  Security Update 2017-001macOS High Sierra 10.13.2, Security Update 2017-002 Sierra, and Security Update 2017-005 El Capitan

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

874 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you