Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree is missing launch shortcuts

Edited

This seems like such an obvious thing that I can find literally nothing about this on the internet.

So, I installed SourceTree. I closed it, and now I want to start it again. There is no shortcut in the start menu, no tile on the start menu, it's not in the 'Recently added' of start menu, and not in the context menu of repositories.

I know it's installed for a fact because when I go to Window Settings/Apps & features then it's listed there with an uninstall button.

I found the exe in %LocalAppData%\Sourcetree but I really doubt this is the intended way to launch it.

44 answers

Under Window 10 you can manually add shortcut to start menu as follows:

Open explorer window and type the following location in the address bar:
C:\Users\%username%\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\

Make new directory named 'Atlassian' and enter directory.

Right-click mouse and select 'New->Shortcut'

Browse to Sourcetree install location : C:\Users\%username\AppData\Local\SourceTree
Select the executable: Sourcetree.exe

Done .-

Alternatively here is a powershell script that will do it (run it as current user):

$objShell = New-Object -ComObject ("WScript.Shell")
$menu_path = $env:USERPROFILE + "\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\"
New-Item -Path $menu_path -Name "Atlassian" -ItemType "directory"
$objShortCut = $objShell.CreateShortcut($menu_path + "Atlassian\SourceTree.lnk")
$app_path = $env:USERPROFILE + "\AppData\Local\SourceTree\Sourcetree.exe"
$objShortCut.TargetPath= $app_path
$objShortCut.Save()

A true saint

Thanks so much! This helped solve the issue for me :) Just a note for a small typo:

C:\Users\%username%\AppData\Local\SourceTree

Like Jonathan likes this

2020.02.18: Still needed!  So thanks a lot!!

Like egibbins likes this

Wouldn't it be awesome if the Setup program could do this for us? <wink>

Like # people like this

This is a horrible bug. I'm using this software because a tutorial is using it, but the second I'm done I'm uninstalling it. If you can't organize your own software onto my machine, why in the world would I trust you to organize my software in development?

Like Prem Patel likes this

Hey ... welcome to 1992 when this was standard practice ... you know, once you install something you need to run it. Seriously? Just manually add a shortcut?!? And the fact that it's a windows app and buried in the many folder layers under appdata folder, that's invisible by default BTW, you can't even easily find it. Really? Wow. I've been developing code since '86. This is an experience of inexperience. Totally Agile! Ship what you got. Let the customer live through a lack of basic development decisions. Love it! Thanks!

Like Corvin likes this

2.5 years on and this is still needed.

 

Wow.

I just downloaded the latest as of Aug 12, 2020.  Shortcuts still not being created. 

Hi,

I have the same problem. After being installed, Source Tree will not show up (Menu, Shortcuts). Only in Settings > Installed apps. And when I open search and paste " %localappdata%\Sourcetree\Sourcetree.exe", the program opens.

Thanks for this Pedro.  How crazy is the problem.  And how come it hasn't been fixed if there are still so many of us having the issue?

Like # people like this

Thanks. How can I find %localappdata% on Windows 10?

minnsey Atlassian Team Dec 19, 2019

Just paste it into the address bar of Windows Explorer and hit return, it will resolve the Environment variable and show you the real location

Atlassian has been investigating this since Feb 27, 2018 lol? I had the same issue, running SourceTree v3.3.6 on Windows 10 v1903 (OS Build 18362.535). I reinstalled multiple times, including clearing the AppData\Local files. I worked around it by just pinning the app to Start on first run.

Like # people like this

I can confirm...  All the way in 2020 now, and still not fixed. Guess Atlassian has little love for Windows.

Like Elisabeth FELIX-GOUTAL likes this

I just spent way too much time looking for SourceTree.exe so I could launch this software. If I didn't have to use it for work I would never touch this app again. I don't understand how such a fundamental flaw has been overlooked for so long.

Like # people like this

I experienced the same issue. Request the maintainer to please look into this urgently. 

I am also facing the same issue. Just spent time googling to figure out where is source tree. Please address this fundamental issue .

@Pedro Raimundo , 

Thank you for this :) 

Thanks for the notes here - I ran/reran the install a couple of times, was about to give up.

How about... at the download link, include a note that no shortcut will be made and where to find the app to pin it?

Hi guys,

I'm having the same problem. The solution I found is the following: (if you installed using the default path): 

1. Local Disk C

2. Users

3. click on your user profile (not Admin/Public).

4. AppData

5. Local

6. SourceTree

and here you should have the app luncher called "SourceTree".

*If you cannot see the AppData folder then click above on the VIEW and make sure that Hidden Items it's checked.

Like sadeeptha likes this

I installed SourceTree 3.3.8 on a fresh Windows 10 machine today.

It's quite unbelievable that it doesn't create any shortcuts or start menu entries. It doesn't even show up when searching from the start menu.

Having to somehow know that you have to go find this app in your Local App Data folder to get it back is just nonsense.

Like # people like this

If this company is unable to succeed with a simple task like adding their program to the start menu, why should i trust them? Uninstalled and used github instead. Finally a software that works!

I used to like sourcetree, but this silliness renders it beyond the robust version control gui I need. Uninstalled and using github desktop. Much better.

I have the same issue.  No shortcut, does not show when you search for 'sourcetree' on the start menu.  It shows on control panel etc, where you can uninstall.  Had to go to the folder where it installed to create a short cut.  Very often not a good thing to do. 

Push "Like" if you subscribed to this thread just because want to know how many years Atlassian will be investigating how to create not missing shortcut for they program :D

bump. more than 2 years for a shortcut fix for real?

I am having the same problem here. A bit annoying.

Just wanted to drop by and make note that I have no Start Menu entry at all. Searching doesn't even pick up the launcher on the computer, only the installer. How has this not be corrected in 2 years? I'm glad I do most of my work on my Mac

Found the SourceTree.exe application under C:\Users\%username%\AppData\Local\SourceTree.

Right-click on the item and select "Pin to Start" and/or "Pin to taskbar".

Same problem
1. No SourceTree start item

2. I have to run SourceTreeSetup.3.3.6.exe to start sourcetree

3. I have to exit and enter source tree everytime I switch branches

The issue of having to exit and enter source tree every time I switch branches was solved by uninstalling 3.3.6 and installing 3.3.4

The same problem.
I have installed program, launched it and it worked. But after closing the program there are no any shortcuts. 
Reinstalling does not help.
Windows 10.

The same problem.
I have installed program, launched it and it worked. But after closing the program there are no any shortcuts. 
Reinstalling does not help.

WIN7 64bit

Like John Wygonski likes this

reinstallng sourceTree also doesnot fix this issue. i see is posted in feb , but still i m getting this issue in my machine.

what is fix to this issue.

minnsey Atlassian Team Nov 07, 2018

Are the Sourcetree files being installed to  %localappdata%\Sourcetree ?

1 vote
minnsey Atlassian Team Feb 27, 2018

Hi

During install a shortcut should be created, we will investigate further why it might not get created.

Uninstalling and re-installing usually corrects this, but if you don't want to do that you can manually create a new shortcut to %localappdata%\Sourcetree\Sourcetree.exe

1. Uninstalling and re-installing doesn't correct, I still get no start item.

2. I can't even use C:\Users\<username>\AppData\Local\SourceTree\SourceTree.exe, I have to use SourceTreeSetup-3.3.6.exe

3. I have to exit and enter SourceTree everytime I switch branches

4. My company is using Atlassian Bitbucket so I wanted to use SourceTree.

Like Adrian Babilinski likes this

So, after more than 2 years, now is that investigation going? ...

+1. Also experiencing this bug. Uninstalling/Reinstalling did not solve the issue, neither did re-indexing windows search. Real bummer. Turns what should be a simple, useful git gui into a big time suck trying to troubleshoot an obscure bug. 

Same here. Tried installing on a fresh machine, no Start Menu shortcut. This is ridiculous.

Why is this still an issue? I have installed and could not find the installation anywhere!  Why does it not install in Program Files like any normal windows program?? Why does the installer not actually create shortcuts??

An answer to your second question, it's a Windows App and not a Win32 binary executable. Windows Apps are different and are installed differently. Win32 32-bit and 64-bit applications line in Program File (x86) an Program Files folders respectively. The first and third questions I cannot answer and have the same questions; Though the first is probably more of an agile issue; enough large customers have to complain and consider it high priority before it's considered something that is high enough priority that it gets done. This has a "relatively" easy yet out of the ordinary fix. 

No clearly they have decided to put it in 'AppData' to save asking users for elevated permission to install in Program Files.  

Downsides include:

- If you switch to a different user account you do not have access to the program anymore and need to install it for that user as well.

- Programs in Program files is more secure, regular and non-elevated users cannot change them, so they are better protected from viruses 

If all programs did this then we would need to install every single application for each user, and security would be broken down i.e any app can self update/change without requesting elevation.  Not practical. 

Still seeing this bug. I'd be willing to work with Atlassian on finding a solution if they reach out.

April 2020, the problem is still there :( wow, so much disappointment. 

The correct definition for Agile development is "if the customer finds a problem, then we will create a story for it. If the 'right' customer finds a problem, then we will fix it.". Nothing wrong with that, but I wish they would just say it.

There is an easy way. Right click -> Pin to Start :))

Annotation 2020-04-20 005118.png

Same issue here. Windows 10 Enterprise (1909). SourceTree 3.3.8. It appears in add remove programs but no shortcuts.

Atlassian, please please open source SourceTree. We will help fix the issues. It's a great tool, but the growing bugs and issues mean it's pushing us to look elsewhere for a replacement. Also the level of discontent in your user base about on going, simple to fix issues doesn't do anything to promote your paid for software. Let this community help with SourceTree and we can show you how great it can be. 

same here

Have the same problem, can't believe that any respectful software can have such issue in 2020

I still have this issue on Windows 10.  For anyone else wondering why the Windows search bar can't find the .exe: by default, Windows excludes "C:\Users\%username%\AppData\" from Windows search.  You can see this by going to Settings -> Search -> Searching Windows -> Excluded Folders.

 

If you manually enter "C:\Users\%username%\AppData\Local\SourceTree" (excluding quotes) into Windows Search bar or the File Explorer folder bar, the folder with SourceTree.exe should show up.  You can right click on SourceTree.exe and pin it to the start menu and/or the taskbar.

Same issue here, except there is no SourceTree.exe file on my PC - I have to run the install every time.

Ending up installing an older version. Still no shortcuts, but at least it installed the SourceTree.exe file.

Me too. "the elephant in the room" bug

is this just because you secretly loathe us GUI using peasants?

Definitely not, lol, if it's the original poster (me) that you're referring to.  The more GUI guidance I get the better!

Same issue here too .  The suggestion to manually create the shortcut into the tool bar works!

Too bad it is not done automatically -  this is a SERIOUS issue as not many people will necessarily have the patience to fight for this to work: search the community for a similar issue, and find this thread with the suggested fix.

 

If I was at SourceTree, I'd at least issue a warning that this may happen and what the workaround is!!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

5,733 views 4 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you