SourceTree initial setup fails on login (403)

Today I was trying to setup SourceTree on a co-workers machine.

While we were able to start the install without issue, when we got to the screen that requires you to log into Atlassian she kept getting a 403 error. The URL from the embedded instance of IE was res://ieframe.dll/http_403_webOC.htm#https://id.atlassian.com/login?application=sourcetree

We were able to log in via Chrome without issue, but as soon as we switched over to IE we got this same error on login. There doesn't appear to be anything wrong with the IE install.

We attempted to login via Google, as well as via an Atlassian user account.

Is there a way to skip this step of the process so we can proceed, or perhaps have it use a different browser? (IE is not set to the default browser on the machine.)

Thanks!

5 answers

1 accepted

1 vote
Accepted answer

In case it helps others, it turns out her Privacy settings in IE (11.current) were set too high.

Internet Options > Privacy > Default (button)

That was enough to get them from High to Medium, and allowed her to log in.

Didn't even think to check these.

Very helpful. I'm sure I'll be linking others to this the next time the issue crops up.

Awesome. Thanks again Seth!

You might try to connect to id.atlassian.com directly in IE, and log in, then try the installation again.

Same 403 error after logging in.

More information details:

This error (HTTP 403 Forbidden) means that Internet Explorer was able to connect to the website, but it does not have permission to view the webpage.
For more information about HTTP errors, see Help.


Outside of initial install issues with one of our other designers, she was able to login without issue.

I'd advise you to check the computer's settings to make sure it isn't using a proxy. I've seen repeated reports of users unable to complete that step of the install who were behind proxies.

Thanks for your help troubleshooting, Seth! Turns out it was an issue with too high of privacy settings.

What version of SourceTree did you install? Are you behind a proxy server?

1.8.3 (Windows).

We don't appear to be behind a proxy server. This morning I was able to login on a different machine without issue.

We also tried again this morning on her machine, both before and after clearing all cookies. I'm waiting to get local admin access to another computer to try on that, as well as another designer's machine.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

831 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you