It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree: how to show commit information panel?

Jason Ji Apr 27, 2015

Hello,

On one of my machines, I have somehow hidden the panel which shows commit information, such as the commit hash and the full commit message. Here is the appearance with the commit panel, below the list of files:Screen Shot 2015-04-27 at 9.17.15 AM.png

 

And here is the appearance without the commit panel:

Screen Shot 2015-04-27 at 9.18.48 AM.png

 

I'm sure it's just a setting somewhere to bring the commit panel back, but I can't find it. Can anyone help me out?

Thanks!

12 answers

26 votes
Fabian Ehrentraud Jan 05, 2017

This single command will only show the commit panel, and not delete any other SourceTree settings. Restart SourceTree after running the command.

defaults delete com.torusknot.SourceTreeNotMAS "NSSplitView Subview Frames repowindow_LogViewDescSplitter"
Joel Mason Jan 09, 2017

Yes, very good!

Dan Lamppa Jan 13, 2017

Thank You! I fixed this issue by replicating what this command does. I edited the plist file "~/Library/Preferences/com.torusknot.SourceTreeNotMAS.plist" manually and deleted the entry for "repowindow_LogViewDescSplitter".

On the Mac, I went to the Finder, opened the "Go" menu and selected "Go to Folder...". I pasted in the path to the file and it navigated right to the file. I double clicked on the file and it opened in Xcode where I could delete the entry.

Paul Beattie Jan 16, 2017

I only deleted

NSSplitView Subview Frames mergesheet_LogViewLowerSplitter

and this fixed it for me.

Dumitru Vilceanu Feb 02, 2017

Running this command in the terminal worked for me also. Thank you Fabian!

Jae young Bang Feb 16, 2017

I have been struggling with this annoying bug of SourceTree for years, and Fabian you have made my life so much better. Thank you very much!

Hari M S Jul 27, 2017

Great solution ! Thanks. 

12 votes
Yanbo Sha May 10, 2016

`defaults delete com.torusknot.SourceTreeNotMAS` will be OK.

Mark Suska Oct 05, 2016

Yes. This works on a Mac.

Beware that this will reset ALL your preferences and you will need to re-login to your Atlassian account. It took me a while to get things back the way I like including Toolbar, Diff tool configuration, and many miscellaneous Preferences.

Chris Nordberg Oct 09, 2016

I can also confirm this works on Mac v2.3.1. You just log back in to your Atlassian account and all your repos are already back ready to go.

SemenovAlexander Oct 12, 2016

+1 it works, however all custom settings got reset (toolbar layout, for instance) 

J M Oct 12, 2016

If you want to save your settings, are familiar with the OS X plist format, and are willing to get your hands a little dirty, use a text editor on ~/Library/Preferences/com.torusknot.SourceTreeNotMAS.plist and delete all the key pairs whose key starts with "NSSplitView Subview Frames".  There are around 25 of them all in a row.  They look like this:

<key>NSSplitView Subview Frames SearchViewDescSplitter</key>
<array>
<string>0.000000, 0.000000, 1101.000000, 309.000000, NO, NO</string>
<string>0.000000, 310.000000, 1101.000000, 423.000000, NO, NO</string>
</array>

 

Deleting NSSPlitView Subview Frames works!

It has been happening a lot recently. Please someone fix this!!!

Yuchen Zhong Oct 23, 2016

The solution is temporary, after a few days, the panel is missing again! sad

Andro Chen Nov 14, 2016

@Chris Nordberg's little app works! thx a lot!

Kyle Cordes Nov 16, 2016

I can also confirm that editing the plist as described above brings the panel back.

Of course, one can dream of a world where someone that works on the project would spot this and actually fix it...

 

Awesome! The tool did the trick! smile

Stephon Harris Nov 23, 2016

👍🏿 @Chris Nordberg's app

Sangharsh Boudhh Dec 04, 2016

In extension to JM's solution, plist file can be open in Xcode and deleting just "NSSPlitView Subview Frames repowindow_LogViewDescSplitter" fixes the issue.

Tony Dexter Dec 20, 2016

@Sangharsh Boudhh's clarification above is excellent.

deleting just "NSSPlitView Subview Frames repowindow_LogViewDescSplitter" fixes the issue

Yuchen Zhong Dec 29, 2016

Deleting all `NSSplitView` entries and it works. Too sad it has been so long and yet they haven't fix this!

Fabian Ehrentraud Jan 05, 2017

This single command will only show the commit panel, and not delete any other SourceTree settings:

defaults delete com.torusknot.SourceTreeNotMAS "NSSplitView Subview Frames repowindow_LogViewDescSplitter"
Joel Mason Jan 09, 2017

Do what @Fabian Ehrentraud wrote. Thanks.

Akiko.T Feb 08, 2017

Thanks, @Fabian Ehrentraud 

I was in the same situation recently, maybe just after update java runtime.
Just now, I've tried Fabian's workaround and it was effective for me, thanks again! 

Mark Turner Feb 15, 2017

Thanks @Fabian Ehrentraud! 

Brittany Scheid Mar 15, 2017

Beautiful, Thanks!

5 votes
Chris Nordberg Oct 19, 2016

Based on JM's comment I wrote a little tool to reset SourceTree's UI. It's here if you want to download it:

https://drive.google.com/file/d/0BzWLwd_TES6XRno2cW82TVNvNTA/view?usp=sharing
Michael Foss Jan 04, 2017

You sir are a scholar and a gentleman.

Fabian Ehrentraud Jan 05, 2017

No need for a tool, just run this command:

defaults delete com.torusknot.SourceTreeNotMAS "NSSplitView Subview Frames repowindow_LogViewDescSplitter"

It will not reset any other SourceTree settings, just restore the commit panel.

Scott Jan 05, 2017

@Fabian Ehrentraud thanks

1 vote
James Mehorter Jul 28, 2015

I'm also getting this now.. anyone know how to show the commit info panel?!?! Soon as this occurred those two little loader animations (sort of cut off below) started displaying like that... 

Screen-Shot-2015-07-28-at-3.12.13-PM.jpg

EDIT: Just got it back!! Started frantically clicking/dragging out to the right, from that top loader animation (sort of cut off in the screenshot) and viola the commit info panel came back. Oddly enough, now commit author photos no longer display.. the question mark icon displays where the author photo used to display. (shrug)

Gatis Rudins Nov 16, 2016

Funny solution, but it helped. Thx.

0 votes
Seth Apr 27, 2015

See if there is an area at the bottom of the file list pane that you can drag upward.

Some other panels in SourceTree have had problems in the past with being able to be resized to zero width/height, and users have trouble finding how to re-expend, but it's typically just a matter of finding the right drag anchor along the edge of where the panel should be.

Full disclosure, I use SourceTree on Windows, which places the commit panel ABOVE the file list, and does NOT allow it to be collapsed to zero height.

Jason Ji Apr 27, 2015

Unfortunately, when I try to drag up from the bottom of the file list pane, it pulls up the "Command History" panel...

Seth Apr 27, 2015

Huh, I don't even know what that is. Can you pull up from the bottom of THAT panel? Might as well try pulling down from the top as well.

Jason Ji Apr 27, 2015

Yeah, unfortunately not - I've tried pulling up and down from various panels without luck :)

Tim Crall Apr 27, 2015

There should really be an option under View to just change all the panels back to defaults. Which version of SourceTree are you using? On 2.0.5.2 I don't seem to be able to make the commit window go away completely.

Seth Apr 27, 2015

Is there any chance you're viewing "Uncommitted changes" in the graph? That panel is hidden when viewing that node, since there isn't a commit to display information about

Jason Ji Apr 28, 2015

I'm on 2.0.5.2, and unfortunately, I'm definitely not viewing "Uncommitted changes" - it's a previous commit. Sorry for the delay in replying; as a new forum member I'm apparently prohibited from posting/commenting more than 3 times in 24 hours.

I'm having the same problem right now. Could you find any solution to it?

Jason Ji Sep 28, 2016

I'm afraid I don't remember my solution, whether it was something clever or just deleting and reinstalling SourceTree. It might have been the latter. (Which isn't actually as big a pain as it sounds, since it doesn't trash your repos themselves - you just have to re-add them to SourceTree.) Good luck!

Thanks, I ended up restoring Source Tree to its factory settings. It seems to be a common problem in the community. Someone should fix or document this.

0 votes
Kimon Roufas Oct 08, 2016

I'm using v2.3.1 (69) on a Mac and have the same problem, can't find a way to fix it. I tried re-installing SourceTree, it didn't help.

You must restore Source Tree to factory settings because it keeps some configuration files on your computer even if you uninstall it.

0 votes
mason Dec 07, 2016

This repeatedly happens to me, and there is a less-invasive fix (at least on the Mac version) than nuking the settings.

Put the mouse at the left edge of where the commit info panel should be. It's tricky because the sidebar resize splitter is in that spot too, so you will see a left-right-drag-cursor (like <-|->). But slowly move the mouse there and you will see a right-only drag cursor ( |-> ). That cursor will let you drag to resize the panel back into visibility.

It's hard to do because it is a difference of 1 pixel. Also this may not work on small monitors question.

Sadly this bug is still present in 2.4.

Mason Mark Dec 07, 2016

Another alternative is to open the prefs file (in Xcode or any plist editor) and delete every row that starts with "NSSplitView...". (This can work if the panel comes back, but the internals of the panel are still fubar.)

 

image2016-12-8 10:37:9.png

0 votes
Pete Cole Dec 12, 2016

I managed to restore this by going to Preferences, changing Window Restoration to "Use Mac OS for Window restoration", then restarting SourceTree. HTH!

Lane Rettig Dec 30, 2016

Didn't work for me

0 votes
Yuchen Zhong Dec 29, 2016
  1. Go to your terminal and type `open ~/Library/Preferences/`, this should open the folder in terminal. 
  2. Find the file call `com.torusknot.SourceTreeNotMAS.plist`, double click to open it with Xcode. I tried open with sublime text but cannot see the content. 
  3. Delete all entries starting with `NSSplitView`
0 votes
Fabian Ehrentraud Jan 05, 2017
0 votes
Kevin Broadey Feb 28, 2017

This has been dup'ed to https://jira.atlassian.com/browse/SRCTREE-4055 which is in the 2.5 release.  I currently have 2.4.1 on my Mac, and https://www.sourcetreeapp.com is offering 2.4.1a at the tie of writing.

0 votes
Rod Bauer Apr 25, 2017

Just in case you edit the plist in some text editor and SourceTree kicks you to login. The plist file is in binary form and saving after editing (like in TextMate) will actually corrupt the plist format in many text editors.

The plist file should be edited in a plist editor, like Xcode.

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

477 views 0 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you