Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree has stopped working.

I am using Windows 7 and Sourcetree 2.x.  Previous answers on this forum were not helping.  I uninstalled Sourcetree, removed all Atlassian and Sourcetree directories in localappdata and in c:\program data, deleted everything I could in localappdata/temp (there's stilla file in use in use called "1"), and rebooted.  Same thing, "Sourcetree has stopped working.

The Windows 7 Event Log shows 2 errors, Application and  .NET Runtime.  I tired poting the event log entries but was not allowed to do so. 

 

3 answers

1 accepted

0 votes
Answer accepted
Mike Corsaro Atlassian Team Jun 01, 2017

Hello! Do you get a BugSplat crash dialog when this happens? Also, could you make sure your version of .NET is upgraded to the latest verison? Thanks!

I'm using .NET Framework 4.6.2

Not sure where to check for bugsplat

localappdata/Atlassian/SourceTree/sourcetree.log is empty

Mike Corsaro Atlassian Team Jun 01, 2017

You would have seen a "Send crash report dialog". If possible, could you post the event log entries too? Thanks.

No "send crash report" dialog appeared.

I tried to send the event logs but got an error:

"Your reply was not accepted. Please check for inappropriate language or spam."

Mike Corsaro Atlassian Team Jun 01, 2017

Fill-free to just attach an image of the error and the details of the error.

Mike Corsaro Atlassian Team Jun 01, 2017

It sounds like WMI may have become corrupted. Could you try the following for me?

  • Open up 'Computer Management' (Right click on the Windows 'start' button)
  • Select 'Services and Applications' (left side panel)
  • Right click on 'WMI Control' > 'Properties'
  • Check and see if the description under "General" lists any error or warning

I'm not seeing "Computer Management" 

Under local services in Component Services I see WMI Performance Adapter and it's status is blank (i.e., not "Started")

Mike Corsaro Atlassian Team Jun 01, 2017

Hit WIN+R and type "compmgmt.msc" without the quotes. You may ignore the WMI Performance Adapter status.

Like Vikash Singh likes this
Mike Corsaro Atlassian Team Jun 01, 2017

Ah, there's the answer: it looks like the "Win32_OperatingSystem" WMI object cannot be found (?!).

 

Check if the repository is corrupted or not by running following command from command prompt with admin rights: winmgmt /verifyrepository. If it is corrupted the returned result will be “Repository is inconsistent.”

If it does not come back as consistent, you'll need to follow the steps here.

You'll need to use "CIMWin32.mof" and "CIMWin32.dll"

It's running--taking a long time

The repo is inconsistent.  I'm going to ask my IT department to take it from here, so there may be a delay in getting back to you. 

Mike Corsaro Atlassian Team Jun 01, 2017

Got it -- thanks for the follow-up.

repaired WMI with:

winmgmt /salvagerepository

and then was able to successfully install sourcetree.  Thanks for your help!

Mike Corsaro Atlassian Team Jun 05, 2017

Awesome! Glad to hear that!

source tree.PNG

I am also facing the similar issues..when i checked WMI control properties there is no issues in that.Can u please guide

Hello @Mike Corsaro, I have the same problem but my WMI doesn't show any errors. Any chance that you could help me solve this problem?

Same here. My WMI showed "Invalid Namespace", but the CMD returned "WMI repository is consistent"
WMI.png
When I try to debug it opens Visual Studio, but doesn't show anything other than "The application is in break mode"

error.png

My WMI was also not working, but I did not have quite the same errors as above and I did the following:

Go into dcomcnfg and try to look at the

Component services > computers > My computer > Dcom config

It may prompt you for classes not registered. Say Yes! Once I did that, my WMI properties were working again and SourceTree reinstalled perfectly.

0 votes

Similar thing happened to me today, instead of "Not Found" the error was "WMI: Invalid class", I got it solved by  following the instructions from TechNet Forum below:

https://social.technet.microsoft.com/Forums/windowsserver/en-US/8c673b55-0db1-4ce1-bfaa-94527e8adb00/how-to-fix-quotinvalid-classquot-in-powershell?forum=winservergen

 

Just in case I will copy paste the steps here too (it is also recommended to make a backup of the WMI repository).

 

. About how to rebuild the WMI repository.

• Disable and stop the winmgmt service
• Remove or rename C:\Windows\System32\wbem\repository
• Enable and start the winmgmt service
• Open Command Prompt as Administrator
• Run the following commands:

cd C:\Windows\System32\wbem\for /f %s in ('dir /b *.mof') do mofcomp %s
NOTE: This will take a minute or so to complete.
for /f %s in ('dir /b en-us\*.mfl') do mofcomp en-us\%s

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,394 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you