Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

Recognition

  • Give kudos
  • My kudos

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree commit author change/update

In SourceTree, how do I update the author that shows in the Author field of the commit UI? it always seems to revert back to a name & email that i don't recall inputting.

1 answer

1 accepted

19 votes
Answer accepted

Hi Patrick,

There are two places this could be happening. Firstly you have a global user details setting in SourceTree. This can be found in the SourceTree menu then "Preferences" (or Cmd+,) and you'll see at the top which user details are used.

If these are correct then there are repository-level settings instead allowing you to override the global settings per-repository. You can find these by going to either the "Repository" menu (when the repo window is open) and hitting "Repository Settings" or clicking the "Settings" button on the toolbar of the repository window on the right hand side. Click on the "Advanced" tab and you'll see some further author details. If the checkbox "Use global user settings" is turned off then it'll be using those author details instead.

Hope that helps!

Thank you for your response! This helped, though I should mention...

I checked both settings, and both showed identical author name & email, but only when I uncheck "Use global user setting" does the commit author change as expected. And, in order for the "Use global user setting" to work when checked (even though both showed the same info), I needed to edit the Default user info and just re-enter the same info.

Thanks again!

Like # people like this

I can confirm this is the case. Version 1.5.2.0 of SourceTree.

You have to clear the "Default User Information" save, then re-type and save before it will update and correctly use this for commits on Repos that are set to use the default info.

Like David_Guerra likes this

Can confirm this behavior on SourceTree version 1.7.0.32059

Issue still exists in 1.9.10.0.  Glad for the workaround mentioned by David. I had to delete my email address from the Default User Information field, apply, open, type in same email address as appeared there before, apply. Now the commit dialog shows the correct info.

Thanks Scott. I had the same issue with 2.0.20.1, and your suggested workaround fixed the problem for me too.

Can confirm - still happening in the version immediately prior to 2.7.1.  I applied the fix concurrent with upgrading, so I can't say if this still exists in 2.7.1.

Like Michael_Minutelli likes this

I can confirm too, it is still happening my version is: 2.4.8.0
What an annoying bug !!! :@ 

Thanks David Scherer,
I got it with your help.

This issue is currently happening in version 2.5.5 also.

Still an issue in 2.6.9. Will it be fixed!?!

2.6.10.0 has the same issue. That is not fun

In my case ExDev who handed-over this computer to me, his ID PW was there as global. I entered mine one and checked use globally. And it worked.

v 3.0.12, still an issue

Like Sergey Semyan likes this

Almost 6 years later and this stills an issue on 2.7.6 macOS.
Need to untick "use global user settings" to manually type name/email on each repo settings :D

I also faced this issue with v 3.0.17.

Now 7 years later, this issue has not been fixed. Bravo !

Just forget it and move on to GitKraken: https://www.gitkraken.com

Like David_Guerra likes this

3.2.6 is still broken.  I looked everywhere I could think of to try to see where it's being cached, but to no avail.  @David Scherer 's method worked for me.  Going to bite the bullet and buy GitKraken before my next project.

Had incorrect author set in my commits too on Version 3.2.6. Unchecking the "Use global settings" checkbox under the advanced repository settings worked for me. Not sure if this is related to the crash on commit issue, when no user.name and user.email is set in git settings.

Behaviour still valid in 3.3.8

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

5,290 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you