It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree can't connect to git Edited

I've been using sourcetree for about 2 years now, a year in the current environment.

Recently, it started asking for github credentials over and over again. At this moment, it doesn't connect at all.

I verified my credentials by logging on to github.com.

I checked the stored credentials in SourceTree under Tools/Options/Authentication. I tried to delete the stored ones - but I can't. I tried to edit the topmost one, but the problem remains.

Any ideas how to make it work?

 

Edit:
In Tool / Options / Authentication I have 3 different entries, all of them are marked as default - and I can't delete them.

1 answer

Another issue might have been that my origins were using http:// urls (as opposed to https://).
I nuked my SourceTree settings (see https://confluence.atlassian.com/sourcetreekb/how-to-wipe-sourcetree-preferences-412484640.html although I found them in AppData\Local\Atlassian, not at the path mentioned in the article).
After restarting SourceTree I could clone github repos again, git communication seems OK now.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,942 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you