Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,464,367
Community Members
 
Community Events
176
Community Groups

SourceTree & keychain fail

SourceTree keeps asking for me password

Here are steps I keep repeating

- reboot my mac

- launch sourcetree

- click on remote I get error

"Error calling askpass for password.

Something went wrong. one or more parameters required to renew token is nil."

- it asks me to sign in on a web view

- i log in no problem (yes my password is valid)

- the list of my remote branches appears

- i click on clone of any of my branches

- apple keychain then pops up asking me for my password, but the very same password that works everywhere else does not work in the keychain

 

- subsequent calls to clone will give me, "This is not a valid source path" and then again 

"Error calling askpass for password.

Something went wrong. one or more parameters required to renew token is nil."

 

Here is a list of things I have tried so far, all in vain

- upgraded from MacOs 10.12.6 to 10.13.3

- upgraded SourceTree to 2.7, then downgraded to 2.6.3.

- deleted my account then added back my account in SourceTree app.

- deleted sourcetree logins from my Keychain Access

- deleted files from ~/Library/Preferences/

- deleted files from ~/Library/Application Support/SourceTree

- added 2 factor authentication then disabled it

- tried basic then tried OAuth

- tried SSH then tried HTTPS

- rebooted a bunch of times. 

 

I have 2 macbooks...  works fine on my other macbook.

 

I am the 4th person in my office to get this problem.  The others have given up and are now using the command line...

 

Screen Shot 2018-03-08 at 11.42.49 AM.pngScreen Shot 2018-03-08 at 11.42.38 AM.pngScreen Shot 2018-03-08 at 11.49.20 AM.pngScreen Shot 2018-03-07 at 11.13.27 AM.pngScreen Shot 2018-03-07 at 11.09.23 AM.png

4 answers

Although I'm a Windows user, my recent experience may be relevant to yours, because it was very similar. The short answer is this: You have *two* installations of Git on your machine. One is the system Git (you can see this version in your command prompt), and the other is the *embedded* Git, which is inside of your Sourcetree application. **When Sourcetree updates, it does not seem to update it's embedded version of Git.**

I was able to solve my very similar authentication issue by - in Sourcetree - going to Tools/Options/Git, and selecting "Use System Git". (My system Git is updated to the latest version.)

Alternatively, there is a button in Sourcetree to "Update Embedded Git" - this should also solve your problem.

Going forward, I'm going to just "Use System Git", so that I only have to maintain Git in one place.

Ultimately, it's two issues:
1. Your password issue needs to be solved by using the latest Git version.
2. Sourcetree is making this difficult by calling it's own version of Git, and then not updating that version of Git when you update Sourcetree

I hope this helps.

After reading through dozens of pages trying to figure out how to fix this issue on Mac (messing with Keychain, reinstalling, rebooting)... A guy using Windows finally gives a real solution with just checking the "Use System Git" option in the SourceTree prefreneces!!! Thanks mate a lot!!! :)

You bet! I should mention (for other people reading this) that it is possible that you only have the embedded Git version, and do not have a system Git version, in which case you would, of course, need to either update the embedded version, or install the system version.

I think it is bad form on the part of the Sourcetree software architects to not at least prompt the user to update the embedded Git when updating Sourcetree. The vast majority of us would choose to do so.

This is still an issue and your solution works perfectly. Thanks!

Still an issue but this resolved it for me too. Thanks!

The Git password (Github /Bitbucket) is (should be!) different from your keychain password. Sourcetree will prompt you for both at different times. The only way I've got Sourcetree to work is to delete the Sourcetree entry from the keychain and read the password prompts in Sourcetree very carefully each time.

If it asks you for your Git password, just type it in. Do not leave "Save in keychain" ticked or you will repeat the problem! When it asks for the keychain password, click "Deny". Unfortunately, you will have to do this every time until a new version of Sourcetree is released that fixes this bug.

Hi Ana, thanks for the reply!

My mac is now seriously misbehaving.  Many apps are no longer working.

The same behaviour I get from SourceTree I am now getting from iCloud: that is my password works on the web site but the same password when prompted from the keychain gives an error.

I think this may be from Apple's new File System.

Upgrading MacOs did not work, I am pretty sure only reformatting will work :(

0 votes
Ana Retamal Atlassian Team Mar 12, 2018

Hi Sophie! You mentioned that you already tried deleting Sourcetree logins from your Keychain, but after that, how did you add your credentials again? Can you confirm if you followed the steps at Connect your Bitbucket or Github account? Or did you do something different? 

Let us know!

Ana

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events