SourceTree + TFS Service + HTTPS: Login failed

Hi,

I'm trying to use SourceTree with MS TFS Service using HTTPS connection to repository. The problem is that when I'm trying to clone my repo - I get a login dialog, fill it in correctly - but it fails to login (it's my Live ID email and password). I'm sure my credentials are correct (I use the same credentials from Visual Studio Git plugin and it works fine there).

Tried to drag-n-drop existing local repo - it reads it all nicely, but when I push - I've got the same logon failure. Specifically, the full output looks like this:

----------------------

git -c diff.mnemonicprefix=false -c core.quotepath=false push -v --tags origin master:master

Pushing to https://myrepo1.visualstudio.com/defaultcollection/_git/MyRepo1

fatal: Authentication failed

------------------

Is there anything I'm missing? Is it a known problem?

Thank you,

Boris.

2 answers

1 accepted

I set up a free TFS account to test this and can reproduce the problem. I can also reproduce it using the standard install of Git from http://git-scm.com - it appears that out of the box, TFS won't work with standard Git.

However you can make it work by allowing 'Alternative Authentication Credentials' in TFS.

  1. Click on your username in the top-right and select 'My Profile'
  2. Select the 'Credentials' tab
  3. Click 'Enable Alternative Credentials'
  4. Click 'Set' next to the secondary user name and pick a username without an '@' character
  5. Set a password

4 and 5 seem to be optional, but I did it anyway. Once I did this, I could clone from TFS using either my full email as a user name or the alternative user name I'd created. It seems like the default TFS authentication is some kind of custom system that only works with the VS tools, and just enabling this alternative authentication makes it work with other systems (why isn't this the default, Microsoft?)

HTH

Works flawlessly. Thanks!

Thanks Steve! this worked for me.

I have alternate credentials set up and am still seeing this same issue. Any thoughts?

Looks like I needed to disable alternate credentials and then re-enabled to get it working. Odd.

Thanks Boss. I spent lot of time to solve this issue. Your solution worked for me. Thanks alot.

I had the same issue. Before implementing the proposed solution I upgraded SourceTree to version 1.8.2.0 just released. Because I already had a local Git repository with a TFS origin, after a while SourceTree asked me for my credentials to the TFS server. I entered my TFS user id and password. Now login to the TFS server works! (I am now able to push and pull to/from a TFS Git repository)

Alternative credentials are no longer available in TFS.

Search google for "Personal Access Tokens" and have a look in the Security link under your TFS account (Top right image of you, Security option is underneath profile)

I've used a full email to log in to other services (Kiln for example) so in theory this should work, but I don't have a TFS instance to test with. The way this works is that Git calls our authentication callback when needed, which is what gives you the login prompt, and those details are passed to the command prompt, so it's hard to know what could be going wrong there - it works with countless other services.

What happens if you use the command line? SourceTree basically just calls git commands under the hood, but it would be interesting to know if TFS prompts differently somehow (although that's unlikely since it's Git providing the prompts).

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

568 views 1 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you