Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree Spinner is spinning forever

Just yesterday I thought it's a good day to install the latest version of SourceTree. Fortunately I didn't listen to the message popping up on startup that I should uninstall my older versions...

The reason for this is that the spinner on the left-hand side where there should be a tree view of the current repo is never finishing spinning. This happens on a quite big repo (current size: 1.86GB; due to binaries being stored in there; something we wanna change in the future but didn't have time for just yet). Smaller repos seem to work fine.

screenshot_spinner_eternally.png

Can anyone suggest a workaround to get it going? For now im falling back to version 1.9. But since there has been issued a security advisory by Atlassian I would like to update to the latest version ASAP.

What I've tried so far is to clean out the C:\Users\%USER%\AppData\Local\Atlassian\SourceTree folder but there was no improvement achieved with that.

1 answer

0 votes
Ana Retamal Atlassian Team May 11, 2017

Hi Marcel, you can try Wiping SourceTree preferences, uninstall the current version and install it again. Let me know if this worked for you!

Regards,

Ana

Hi Ana!

Unfortunately this didn't resolve the issue. Do you have any further advice?

Best regards
Marcel

Ana Retamal Atlassian Team May 16, 2017

Hi Marcel, there was another user with a similar issue, he removed his repo from SourceTree and cloned it again and it started working. You can see his response here.

Did this work for you?

Cheers :)

Ana

That is merely a workaround - and not a good one I have to say. I have local branches that I cannot throw away just like that. Also my stashes will be lost. This is rather a last resort thing. I will do so eventually if I'm forced to. Nevertheless I would highly appreciate if you could pass this problem on to the developer team so they can look into it so that bug can be fixed in future releases.

I'm having the exact same issue as Marcel. In the mean time I've reinstalled 1.9 but would appreciate an actual fix since, as Marcel documents very well, wiping a repo is not really as easy as simply deleting a few folders :)

Ana Retamal Atlassian Team May 17, 2017

Hi! Indeed, that was a workaround whilst the actual fix gets rolled out. I already informed the developers about it, as I mentioned in the other thread :)

Best regards,

Ana

Same problem here. Spinner is spinning forever. Repo has a lot of local branches and some stashes, so I reverted back to 1.9 . 

Same problem here.  I posted another question on this before I saw this post.

Same problem here - 4 years later :). Atlassian - great company as always

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

4,360 views 4 8
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you