SourceTree - Loses changes and remotes

Sorry about my poor wording here.

I have been using SourceTree for many months, and recently I installed manual git msys for bower. Then I had all sorts of problems and abandoned bower usage and uninstalled git.

I reinstalled SourceTree several times.

The problem is that SourceTree acts normally when I first boot up the PC. It shows me my remotes, and shows me my changes. Just as I always expect.

However, after an unknown time (and often instantly, on first launch) it appears to lose all connection to data. This screenshot shows that all my remotes are gone, and that all changes are being ignored.

http://imgur.com/iDWJqyh



Does anyone know why SourceTree is dropping like this?

Thanks for your time :)

2 answers

This widget could not be displayed.

For me it was comodos auto-sandbox. I do not recall changing anything which is odd.

https://answers.atlassian.com/questions/190694/my-sourcetree-don-t-want-to-show-the-log-it-says-git-log-failed-with-code-128-with-no-messages<br< a="">>
Sorry for the dud post.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

868 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you