It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree Half installed. Waiting for login to finish

I had a version 2.x installation of SourceTree on Windows 10 that kept telling me I was already up to date so I decided to manually update by downloading the installer from the website.

I am struggling to get the install complete because the login won't finish and because of this I appear to be completely locked out of SourceTree until this is resolved.  I wish I'd not bothered to update now.  Anyway I need to get out of this vicious circle so any help will be greatly appreciated.

I've selected to Login to Bitbucket during the install process and entered my credentials which have been accepted, I am using Chrome as that's my default browser.  I get to the page which says....

 

Confirm access to your account

Sourcetree for Windows is requesting access to the following:

 

...and when I hit the Grant Access button it just takes me to an error:

 

This site can’t provide a secure connection

localhost sent an invalid response.

 

and I'm stuck.  I don't appear to be able to back out of this and just launch the application, only the installer, which requires me to register, but the registration process won't complete so I'm stuck unable to use SourceTree because the login process fails and it won't let me side-step it to get back to doing some productive work.

I searched the community for other installer problems and they all appear to be IE related and latest information suggests that the latest installers no longer rely on IE and this annoying login process should work on any browser.

Help!  I just want to get back to using the application and don't understand why this login nonsense has been allowed to break installations.

4 answers

It worked for me:

copy url and change https to http and open in iexplorer.

That works for me too. thanks

0 votes
Mike Corsaro Atlassian Team May 15, 2019

Hello! This is probably due to a non-default setting in Chrome, your local internet security settings, or possibly anti-virus.

 

Could you try the following and see if any of them work?

  • In the URL, change 'https' to 'http' (something might be forcing it to use https)
  • Try changing the 'localhost' part to '127.0.0.1' and try navigating again
  • Try changing your default web browser to something else, or copy and paste the end result URL into another browser

Chrome was forcing https. Changing to http and opening in Firefox fixed it for me.

0 votes

version 3.0.17 worked 4 me

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,895 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you