Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree - Commit button / Commit files step doesn't work - any additional tutorials I can use? Edited

I've followed the SourceTree tutorial here: https://support.atlassian.com/bitbucket-cloud/docs/create-a-new-repository/ 

  • I got to Step 2, Part 6, and while I have my "Supplies.txt" file in the Staged Files section of SourceTree, the Commit button does not appear to do anything (and it doesn't bring up the message box in Step 2, Part 6). 
  • There must be something I've missed somewhere - can I request help with this issue please?

 

What I've tried so far:

  • Following the tutorial
    • Everything in the tutorial appears to work up to this point (creating new accounts, installing SourceTree, creating a new repo, exploring in BitBucket, cloning repo to my local system, creating a file locally, having the newly-created file appear in SourceTree)
  • Shortcut keys (CTRL+1 && Shift+Alt+C)
  • Ensuring the new file is selected before hitting Commit / shortcut keys
  • Checking the user forums. This link appears to be the issue I've run into, but there are no answers in the thread: https://community.atlassian.com/t5/Bitbucket-questions/Cannot-commit-new-files-using-SourceTree-Git/qaq-p/1106751
  • I've also tried continuing on through the Learn SourceTree and BitBucket tutorials, and Push also does not work for the new file (probably because the previous Commit step does not work)
  • Closing out of the web browser and application, and re-opening / re-signing in

 

Thanks!

1 answer

0 votes

Of course I found my answer shortly after I had posted it here - and since it doesn't look like anyone has the ability to remove their own posts / questions, I'll share what I missed in case others run into this:

  • In the tutorial link, Step 2 Part 5 says to click the Commit button at the top.
  • Clicking this button at the top didn't appear to do anything.
  • Step 2 Part 6 says to enter information into a message box - I expected that clicking Commit at the top would bring up a message box, and it doesn't. So this appeared to be broken.
  • Instead, the message box is at the bottom or the screen, which has its own Commit button - and this is the one that actually executes the action. I entered my comments in this field, ticked the "Push Changes Immediately to Origin/Main" property, and then clicked on Commit in the bottom right of the screen.
  • It appeared to do a thing the first time I interacted with it, but nothing showed in History. I had to try a second time and then that appeared to work.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

4,370 views 4 8
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you