Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree 3: Connecting to VSTS

I'm trying to connect to my to my VSTS remote repo using the new version of Sourcetree (3.0.8). I have the chosen "Visual Studio Team Services" and put in the Host url (https://{organisation}.vsualstudio.com)
The only option is to "Refresh Personal Access Token". This gives me a pop up requesting username and password. This fails with not authorised and the username field is not filled in. If I instead use a PAT for the password, the username field is now populated with my username but is still not authorised and says I don't have access to "https://app.vssps.visualstudion.com"

What am I doing wrong?

4 answers

The hosting URL works for  https://xxxxx.visualstudio.com/ but not for the new URL system that devops uses/recommends https://dev.azure.com/xxxxx/

Get the token from in Azure Devops in the Create Token area.

Okaay, so 30 mins later, I'm ready to go...

Also looking for an answer to this question, however I may be even more out of luck -- I'm trying to connect to a locally-hosted instance of azure devops. Would love a fix or workaround.

0 votes
minnsey Atlassian Team Oct 26, 2018

Hi

In principle you are doing the right thing.

I have noticed on occasions you need to enter the PAT twice, at this stage I don't know why. After the first failure if you try and enter the PAT again, you might find the username information pre-filled, enter the PAT and click OK and you should find it works.

I have the same problem, I've spent hours and hours and tried different URL for host and different UserName but still no success. 
The most closed way to put credential is like this : 

You better put https://YourOrg@dev.azure.com/YourOrg as Host URL and your email as username and your token as the password. but still getting this error : 

 

failed.jpg

I wish there was a tutorial from sourceTree team how we can work with AzueDevOps. Even when we choose Visual Studio Team Service as Hosting Service, The Username field is disabled and you cannot put any value. The way I worked around was I chose BitBucket server, then username field was active, I put my email and then changed to VSTS otherwise there is no way to put username.
It's a pity such a great tool has this big and obvious problem and lack of document.

Like # people like this

Same problem here...

Like humzaqadeer likes this

I finally got it to work.  here is what I did. 

1. Select "Visual Studio Team Services" as Hosting Service.

2. For host name, use https://[yourname or org name].visualstudio.com/

3. Click on Refresh Personal Access Token, and type in your MS account user name.  For password, enter the token that you have generated from Azure DevOps.

- To generate a token, login to Azure Dev Ops.  On the top right menu, click on the circle with your initials and select "Security".  Generate a new one token.  Give it a name, e.g. SourceTree (not important), and copy the token to be used with SourceTree.

4. Here is the tricky part -- On SourceTree, I tried several times and it kept saying authenticated failed.  I finally (through random frustration) clicked on the error message itself and it refreshed and say "Authenticated".  Definitely buggy.  Good luck.

Like # people like this
minnsey Atlassian Team Mar 11, 2019

Interesting, thanks for the update.

The error message isn't actually an active element, just a textbook, I'd guess there was just a log between old error messages and the new success coming through and being  shown.

I followed Lhkengs instructions:

However:

I am on the new  https://dev.azure.com/xxxxx/         domain

This uri is not accepted via sourcetree as constantly unable to verify

If i revert back to the old address of  https://xxxxx.visualstudio.com/  and use same credentials it is successful.

Then when i go into clone a repository:

I get This is not a valid source path / URI

https://xxxx@xxxxxxx.xxx@xxxxx.visualstudio.com/[repository]

 

 

It is very weird but, after entering the PAT for couple of times it did work. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,375 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you