Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,461,218
Community Members
 
Community Events
176
Community Groups

SourceTree 3.4.8 stopped connecting to GitLab EE 14.10.2 using Personal Access Token

Hello All,

I wonder if anyone experienced this issue:

We upgraded our self-hosted GitLab EE to 14.10 from 14.0 and configured it with https. 

SourceTree version 3.4.8 (Windows)  stopped connecting to GitLab using Personal Authentication Tokens.   When running GitLab on regular http everything works fine.  As soon as we turn on https, SourceTree stops connecting.  Old version of GitLab (14.0) worked fine with http and https. 

We turn on verbose logging on SourceTree, but there is nothing in the log. 

The only error we see is on the authentication window is "Authentication Failed"

Steps to reproduce:

Tools -> Options -> Authentication Tab

Enter following: 

Hosting Service: GitLab EE
Host URL: https://myserver.com
Preferred Protocol: HTTPS
Authentication: Personal Access Token

Click "Refresh Personal Access Token" -> Enter user id and Personal Access Token as a password.

The only error we see is on the authentication window is "Authentication Failed"

 

On the GitLab side we see the following in the nginx log:

SSL_do_handshake() failed (SSL: error:1417A0C1:SSL routines:tls_post_process_client_hello:no shared cipher) while SSL handshaking, client: xyz.xyz.xyz.xyz, server: 0.0.0.0:443

 

However, regular browsers connect just fine.  Also I ran openssl s_client and it reports the following protocol and cipher.  

SSL-Session:
Protocol : TLSv1.2
Cipher : ECDHE-RSA-AES256-GCM-SHA384

 

 

I'm not sure what is wrong and I appreciate any input or suggestion.

 

Thank you!

 

 

 

 

 

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events