Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree(2.7.4) crashes on launch in Mac OS 10.13.5

SourceTree(2.7.4) crashes on launch in Mac OS 10.13.5

 

If SourceTree is not compatible with Mac OS Sierra, what is the proper alternative way?

 

4 answers

Since this morning I have exactly the same problem.

Having the same issue on Mac OS 10.13.4 with SourceTree 2.7.4. I am able to get it to work long enough to work with it but it will on the next start. There's two things I'm doing to get it to work temporarily. First I delete the SourceTree folder in Application Support.

~/Library/Application\ Support/SourceTree

Then I have to add all the repositories back into SourceTree. That worked yesterday but when I started up today it crashed again. I don't like that solution so much.

Today I tried moving my local repository folder to a new location where SourceTree could not find it. That allowed it to start. Then I moved the folder back to where SourceTree is looking for it, I added the repositories back in. That worked for a few minutes before crashing. I'm thinking that maybe one of the repositories is corrupt?

This all works fine on my Windows 10 machine.

 

Here's my error log:

Process: Sourcetree [1551]
Path: /Applications/Sourcetree.app/Contents/MacOS/Sourcetree
Identifier: com.torusknot.SourceTreeNotMAS
Version: 2.7.4 (175)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Sourcetree [1551]
User ID: 501

Date/Time: 2018-06-06 07:53:51.113 -0400
OS Version: Mac OS X 10.13.4 (17E202)
Report Version: 12
Anonymous UUID: 37BC183C-8428-0D62-1531-7D654FEF3BAB


Time Awake Since Boot: 3200 seconds

System Integrity Protection: enabled

Crashed Thread: 12 Dispatch queue: com.apple.root.default-qos

Exception Type: EXC_BAD_INSTRUCTION (SIGILL)
Exception Codes: 0x0000000000000001, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Illegal instruction: 4
Termination Reason: Namespace SIGNAL, Code 0x4
Terminating Process: exc handler [0]

This seems to be working...I move my folder of repositories out of where SourceTree expects it, launch SourceTree, SourceTree shows that the repositories are gone, and then move the folder back without first quitting SourceTree. SourceTree then auto updates.

I've quit SourceTree and relaunched a couple times and it worked. I don't have confidence it that lasting for long. It's too buggy for that level of confidence. At least I can work.

So far, for me this also seems to be working. Thanks!

Unfortunately it only worked for a short while. Often it starts crashing again. 

Mine seems to be working well so far. I did have some crashes at the beginning.

0 votes
Manju Atlassian Team Jun 06, 2018

We are investigating the crash. There seems to be an issue loading and reading repo avatars. We will soon have an update on this. In the meanwhile, feel free to remove the ImageCache folder under ~/Library/Application Support/SourceTree/

Thanks for your patience! 

Manjunath

Sourcetree Mac Developer

For me this started when I tried create a new repository on Bitbucket and then clone it down to my Mac. It was an empty repository with just a README.md in it. Crashed right after the download and didn't work. Now it seems to be working reliably.

Manju Atlassian Team Jun 07, 2018

This was primarily due to a change deployed by Bitbucket cloud that was reverted in time. Also, we made a release of macOS client to ensure this type of a crash doesn't happen again. Thanks for the understanding and kind cooperation. 

Cheers,
Manjunath

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,292 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you