SourceTree 2.4 does not store GitHub password in keychain

Since installing SourceTree 2.4 I've had a number of authentication issues (with GitHub). Only one of the possible ways to connect with a GitHub remote actually "worked":

  • I create a personal access token on GitHub
  • I pull from my GitHub remote
  • I am asked for username and password (= personal access token)
  • This prompt is shown again, and I enter my credentials a second time, after which the pull succeeds

Screen Shot 2017-01-23 at 14.43.30.png

 

Ticking the checkbox to store my password in Keychain doesn't do anything: I am shown this prompt every time, always twice. From checking the verbose output, I notice it's one time for the fetch, one time for the pull. So my password just isn't saved to Keychain.

Screen Shot 2017-01-23 at 14.51.02.png

I tried entering my username and password / access token after doing a git pull in Terminal, which used to fix this kind of problem in previous versions, but not now.

I also experienced these problems with auth in 2.4:

 

So in order to continue working, I removed 2.4 and installed 2.3.2 again.

 

1 answer

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

712 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you