SourceTree 2.0 ssh-agent hangs during commits and some generic rants

We have updated to SourceTree 2.0.20.1 because of the critical URL handler issue in previous versions from 1.5.2 and because we use a local Atlassian Bitbucket server and don't want to miss out on the checkout from browser feature. Overall the UI performance and reliability compared to that really old version has degraded a lot.
First step was the workaround needed to get the URL checkout from Bitbucket working again: https://jira.atlassian.com/browse/SRCTREEWIN-7209
Next to the overall complaints about the tabbed UI for repositories that is being discussed a lot on the community here we have had no serious crashes. (Today was the first crash report to bugsplat sent that happened during shutdown of the Windows 7 64Bit machine)

The more annoying issue is the overall slowness of the UI especially when during commits the ssh-agent seems to freeze. Sometimes killing the ssh-agent task from the Task Manager allows you to finish the currently frozen action (commit, pull, fetch) but in other cases you just have to repeat it after the ssh-agent has been killed.

And because I wanted to mention this here again:
Another issue is that was reported from other teams that also upgraded to version 2.0 is that doubleclick on a file does not open it like before.
https://jira.atlassian.com/browse/SRCTREEWIN-7250

3 answers

This widget could not be displayed.

Hi

First thanks for the feedback, good or bad, its good to get. (thumbsup)

With respect to performance, it might be worth raising a ticket at https://jira.atlassian.com/projects/SRCTREEWIN.

It would be useful to know how/when the ssh-agent freeze occurs, how you know that is the issue as the ssh-agent is usually a background task, not very visible. Also did you upgrade git version when you upgraded SourceTree? The ssh-agent is part of the git distribution rather than SourceTree itself.

Thanks

 

Hi Michael and thanks for the follow-up.

At the moment we just have the feedback from three different teams that working with the new UI (again we updated from 1.5.2 -> 2.0.20.1) feels slower and is more prone to lags or the described freezes while the old version was a reliable workhorse that just worked.

Since our IT also manages our applications we are on Git for Windows 64Bit 2.12.0 and the current SourceTree 2.0.20.1.

For evaluation we will also follow the beta program of SourceTree on a selected VM and from what I have seen improvements are being made. Will also try and get a better grip on the freeze and ssh-agent hangups - maybe check out a newer version of Git for Windows there.

Since coming back from almost 2 weeks of vacation one more thing that was already discussed at length in the forums was again high on our complaints list - the blur effect related to WPF font rendering at https://jira.atlassian.com/browse/SRCTREEWIN-7199

best regards,

Michael

 

 

This widget could not be displayed.

Today the ssh-agent process needed to be killed again. It was a small commit with 2 changed files. I had enabled the option "[x] Push changes immediately to -" and under [Commit options...] "Create Pull Request".
I left the client open for at least 30 minutes to see if it would recover ... but it did not.

After killing the ssh-agent the UI unfroze and the dialog showed the error message:

git -c diff.mnemonicprefix=false -c core.quotepath=false commit -q -F C:\Users\myuser\AppData\Local\Temp\tempfilename.tmp

git -c diff.mnemonicprefix=false -c core.quotepath=false push -v --set-upstream origin fix/branchname:fix/branchname:fix
Pushing to ssh://git@bitbucket.server-url.de:7999/tst/repo.git
Authentication failed.
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

Completed with errors, see above.

 

 

I could not add the system details (Please check for unappropriate language or spam): 

The commit happened, but the push did not complete.
OS: Win 7 SP1 64 Bit
Git version: 2.13.1
SourceTree: 2.7.1.0

Do you get any similar behaviour if you use the git terminal to run the commands? It should be using the same ssh-agent etc.

No. git on the console is typically lightning fast ... never had any authentication issues or hangs using the OpenSSH key authentication against our local Bitbucket server or one of the few github repositories. I am always switching to the terminal (Git Bash) when SourceTree (or now Sourcetree) hangs and I am too lazy to kill the aah-agent process.

Does PuTTY behave any better?

I have not tried using PuTTY since OpenSSH integration seemed the way to go to be able to use console and Sourcetree in parallel. Also because some of our scripts are now also executed on linux machines. I could switch to PuTTY for a week and give you feedback if you think that might help. Running windows PuTTY seems better integrated. On first try the server key was outdated. I confirmed the security warning and restartet Sourctree. --> crash (no bugsplat window).

Will give you feedback next week if PuTTY integration works better.

This widget could not be displayed.

 

Mhm ... strange ... the profanity / spam filter did not trigger when I added the details editing the post line by line.

Yes, its an odd like that

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

735 views 1 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you