Source tree painfully slow on mac

I watched this thread, but it seems to be focused on Windows 7 and not apply to me

https://answers.atlassian.com/questions/10413451/sourcetree-slow-in-windows-7-x64...

I've always found SourceTree to be very slow. Lately though, it's gotten out of hand. Especially since native git and GitX is orders of magnitude faster. What I mean by that is that the UI freezes a lot (I get the spinning bathing ball for many seconds). For instance, this happen when I click a file in the "Unstaged" area, so it's added to the "Staged" area. Now I have to wait a couple of seconds before I can click on a file in the "Unstaged" area again. Also just scrolling in the "Unstaged" area is very slow.

Some more information

  • I'm on a 2014 MacBook Pro
  • Using Yosemite
  • I don't have a lot of unstaged files (right now maybe 10-20)
  • I don't have a lot of pending files (right now maybe 20)
  • I've set the binary diff limit to 0
  • I do not use submodules
  • I've tried both embedded git and system git
  • Restarting seems to help a bit, but it's never really good

This is really painful. Any way I can help out by sending dumps/more information?

 

10 answers

I found a solution working for me:

I realized that SourceTree used the embedded git with version 2.1. I installed via brew git 2.3 and switched sourcetree to using my brew-git. 

Tada: Now SourceTree is fast, again.

Steps:

  • brew install git
  • SourceTree -> Preferences -> GIT -> Use Sytem Git -> Select /usr/local/bin/git

 

 

I did this, seems to be faster so far. I'll post an update in a few days to see if it stick. Thank you Sebastian.

Update: Changes did not help after all. Still experience the same sluggishness.

Thanks @Sebastian Gabbert, seems faster now

I use Sourcetree version 2.7.6 (177) on MacOS High Sierra and can confirm that it's still works extremely slow. Every action takes ages. Switching to use internal git, as suggested in above messages, doesn't change anything.

Same experience here, on Sierra.  It's a sad fate for such a great tool.

exactly the same here. Same Setup, same problems.

I've seen the spinning ball especially building the diff and staging large css-files for several seconds.

Thanks for the reply @Sebastian Gabbert. I think you're right. First it was even slower, but then I restarted Source Tree and now it's actually faster again. It seems something is fishy in ST as well though. Thanks for the advice!

Ok, now I've tried this for some time. And the problem is really not fixed by that. And not restarting either. I get a LOT of bathing ball time. 10 seconds is not uncommon. As a comparison running git status from command line takes 0.15s.

I've been having this issue quite a lot lately especially when I scroll down the commits scroll view. It'll chug for 0.5s every 10 or so commits I scroll down. It's extremely annoying.

Mine seems to be working now on my Mac.  I've been seeing significant performance issues with SourceTree as well.  Tried many things (including suggestions here) and it continued to be very slow. 

I finally changed the view from 'log' to 'file status' and then back again and now it's speedy again. IU believe the UI might have  a memory leak that gets reset upon view change(I know, doesn't make immediate sense). I'll post updates if things change.

Mo

this worked for me, thanks for feeding back ;) atlassian, please fix!

Using the system git fixed the issue perfectly.

To anyone having a slow Sourcetree app in Mac, do the following:

  1. Click on the Sourcetree menu.
  2. Click on the Preferences... menu item.
  3. Click on the Git tab.
  4. Below, in the Git Version, click on the "Use System Git" button.
  5. DONE.

Switching to System Git, in my case 2.13.1, doesn't change anything on macOS High Sierra.

Maybe the problem is with the Git version. Try updating it to the last one.

Possibly. I'll upgrade the Git itself through brew and then we'll see.

Upgraded git to 2.19.1 and use System Git (as I have set) seems now works better. I guess I'd need to work some time to justify performance improvements.

0 votes

Changing to the system git did the trick for me.

Thank you!

0 votes

Told SourceTree to use local git version, restart SourceTree and nothing has changed. Then 2 minutes later it was slightly faster, and then again slow, but it's a bit less frequent.

It seems to me that SourceTree want to rescan the whole repo every time you click on something.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

715 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you