Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,545
Community Members
 
Community Events
176
Community Groups

Source Tree freezes when merging

Every time I try to merge from another branch to my branch, source tree will have a progress bar forever. I've waited over an hour for anything to happen but nothing does.

If I do it through the terminal it works fine, it's only in the gui. This happens on more than one machine as well. I believe it's getting stuck after downloading the branch but it does not get to the filtering step.

Any ideas?

2 answers

0 votes
Mike Corsaro Atlassian Team Aug 27, 2018

Hello! I suspect file refreshing is stuck in a loop, could you try disabling auto-file refresh and try again (go to Tools > Options > General > Uncheck 'Refresh automatically when files change'). This has been fixed in the upcoming 3.0 release.

 

If it doesn't work after trying that, could you do the following for me?

  • Open the Process Viewer by going to "Tools > Process Viewer"
  • Try the merge again, and observe what happens in the viewer (I suspect you'll see a ton of processes running)
  • If there's a single process that seems to be running forever then save the log or screenshot it so that I can see the details of the 'Caller Context' and 'Command" columns

 

Thanks!

Tried the above and thought it worked but again ran into a merge that did not end. Here's the log I got https://drive.google.com/file/d/1XikXO8SGKsAVBZy-HAv2ncTvt9jRKiJL/view?usp=sharing

I should note that using the terminal, this merge took under 5 seconds

0 votes
Manju Atlassian Team Aug 22, 2018

What version of Sourcetree is this happening with? Is this on Windows or on the macOS?

Version 2.6.10.0. Some machines might be on a higher version than this but this would be the lowest.

Windows

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events