Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,365,715
Community Members
 
Community Events
168
Community Groups

Source Tree crashes on start and installer has no GUI.

Edited

Source tree has stopped working on my windows 11 machine. It was working just fine and then when I run the executable today it crashes before loading the main UI. Version 3.4.6

I tried uninstalling and then deleting all the directories in app data and tried reinstalling. When I tried to running the installer 3.4.7 no GUI is present and it appears to crash. However it appears to install SourceTree silently. 

sourcetree.log:

2022-01-05T17:31:54: LogHost: Initializing to normal mode
2022-01-05T17:31:55: CompositionException [Import "SourceTree.Analytics.Services.AnalyticsService.MauSubmissionService" could not be satisfied.]
ERROR [2022-01-05 17:32:11,145] [1] [Sourcetree.Composition.VSMef.Net471.CompositionExceptionHelper] [Log] - CompositionException [Import "SourceTree.Analytics.Services.AnalyticsService.MauSubmissionService" could not be satisfied.]
ERROR [2022-01-05 17:32:40,977] [1] [Sourcetree.Composition.VSMef.Net471.CompositionExceptionHelper] [Log] - CompositionException [Import "SourceTree.Analytics.Services.AnalyticsService.MauSubmissionService" could not be satisfied.]

 

Running the installer or SourceTree brings logs a CompositionException for "SourceTree.Analytics.Services.AnalyticsService.MauSubmissionService". 

 

Very frustrating.

 

How does sourcetree install without going through the install prompts? How do I do a clean install of truly clean install of sourcetree?

 

Edit

--------------

So I turned on debug level to the logging file for my non-working version and for my laptop which has a working version. The different appears to be a difference in the assembly requirements.

 

My broken PC version tries to reference "SourceTree.Analytics.Services.AnalyticsService.MauSubmissionService" which is not part of the packaged assemblies.

My working Laptop version uses "SourceTree.Analytics.Emau.EMauSubmissionService" whos assembly is included in the install on both of my machines.

 

Why is my PC suddenly trying to use a different assembly that is not included in my package? How do I make it go back to the assembly that is included in my package? 

 

 

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events