Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Source Tree Stuck Logging in "Please Wait"

Other users on same box can log in however I get "Please Wait" and never logs in. 

2 answers

1 vote
Ana Retamal Atlassian Team Jan 25, 2018

Hi! Can you give us some more information so we can help you troubleshoot this issue?:

  1. Are using Windows or Mac?
  2. Which Sourcetree version do you have?
  3. In which stage are you getting this error? Is it when you enter your email address?
  4. Can you provide a screenshot?



1. windows server 2012 R2 


3. when enter email / password 

4. will obtain shortly.

Ana Retamal Atlassian Team Jan 26, 2018

Hi! Seems like you haven't been able to get your screenshot yet. We've seen several users having trouble to authenticate when on Windows so, in the meantime and lacking some information to troubleshoot your specific case, I'd recommend you to update Internet Explorer to the latest version, as Sourcetree relies on it for authentication and many issues have been solved like that. 

Let us know if this works for you!

Best regards,


Also tried updating IE with no luck

Ana Retamal Atlassian Team Jan 29, 2018

Thanks for that! Can you try turning off Internet Explorer's Enhanced Security Configuration:

  • Turn off compatibility mode in IE. To do that, open Internet Explorer, go to the Advanced options tab and click on Reset your Internet Explorer Settings
  • Check Delete personal settings
  • Change your Internet Explorer Security Zone Settings:
  1. Open IE, click on the gear
  2. Select "Internet Options"
  3. Select the "Security" tab
  4. Select "Custom Level" for Internet
  5. Find "Access data sources across domains" and select "Enable" (make note of what the setting currently is)
  6. Try logging into Sourcetree again

After logging in, follow steps 1-5, but reset the setting back to the previous option.

The same happens with many users. Hit the search on google and see yourself thousands of such messages. Why did you have to make a mandatory entrance to Atlassian Account without special need? You spoiled a good application with a useless login to the Atlassian account.

Like J.Statkus likes this

Is there a solution yet? Tried installing sourcetree on windows server and i am stuck on an infinite "please wait.."... is there any way to access logs to know what is failing?

The workaround i used was to not use sourcetree, used GIT shell instead with the command : git clone [repository-url].git (this command can also be obtained using the feature "Clone this repository" available on bitbucket).
The funny thing here is that an authentication popup from atlassian shows up an it works normally... 

Like maximealarcon likes this

It is too bad. Our company disallows us to touch "Internet Explorer Security Zone Settings". Actually the Security" TAB is hidden by admin.

No words!!

You guys can setup sourcetree and login on a non-windows-server computer where it works, then copy accounts.json and passwd from AppData\Local\SourceTree to your Windows Server


Worked for me anyway :)

Suggest an answer

Log in or Sign up to answer

Atlassian Community Events