It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Source Tree Start Menu Icon missing in Windows 10

A couple of months ago I did an update to Source Tree and the icon disappeared. I was too busy to do anything about it at the time but would like to have this fixed as it is bothering.

So far I have unpinned sourcetree and repinned but that did not fix the icon. Not sure how to proceeed. Attached screenshot of the start menu with sourcetree missing icon.

 

Capture.JPG

10 answers

1 accepted

5 votes
Answer accepted

Un-pinning, re-running the full installer, then re-pinning fixes the icon (and all your SourceTree configs are retained).

(No need to completely uninstall and then re-install.)

Thank you, Dominic! I've marked this issue as resolved by this process.

Regards,

Shannon

Like Francis Dale P. Cabrera likes this

In the windows search bar type sourcetree*exe

Hi All,

Please find the shortcut in below folder location.

     C:\Users\username\AppData\Local\SourceTree

 

if you upgrade from older versions to 3.3.6 (latest ) there will be no issues in getting shortcuts on start menu or on desktop.

 

Thanks,

Just installed 3.3.6 on Windows 10 and no shortcuts were installed on start menu or the desktop.

I added them myself, but it is annoying.

Like # people like this
Snorvarg I'm New Here Jan 28, 2020

This worked fine, right-clicking the exe file and pinned it to start. Odd bug anyway, did not help uninstalling and installing again. (Can confirm settings do not disappear when reinstalling)

I have the same issue with version 3.3.8 installed today on a fresh Windows 10 build -- no link added to either the desktop or the start menu.

Like Uilstuguldur_Batbold likes this

There's a defect that's been open for quite a while regarding this, I recommend anyone else interested add their two cents' to it:

https://jira.atlassian.com/browse/SRCTREEWIN-8376

Good news ! This has been fixed by version 3.3.9 (at least, for the start menu), even though that specific JIRA ticket has not been closed.

I added a comment to

https://jira.atlassian.com/browse/SRCTREEWIN-8376

with details of my own experience.

2 votes

Honestly Atlassian,

this speaks to the quality of your products.

In reality, SourceTree is a weak bandaid that allows me to recommend lazy solutions to some of the bitbucket tasks.  I don't generally use it because it really sucks at merge management with reasonable branch collisions.

And then the fact that you do not care to fix an obvious glaring issue after 3 years???

I'm pulling this app from our company recommendation list for data science and software support.

Tired of telling people how to fix this idiotic problem.

The windows installer has been non-standard for years. Just got another computer and dismayed to find this hasn't been fixed. There should be a normal installer that puts your program into \Program Files, not in AppData. This is crazy! No program except source tree does this, and it causes so many install problems for users.

Sourcetree is definitely not the only program that does this, but I agree it's nonetheless quite annoying.  Installing to the user profile directory is done by many programs (Chrome used to do this by default, for example, but not any more), normally when admin privilege is not available.  This non-standard location should be a fallback for that particular scenario only, not the standard practice. 

Please, by default, follow Windows best practices.

Like # people like this
0 votes
minnsey Atlassian Team Dec 28, 2017

Hi

I've not experienced that problem, it looks OK for me. There was an issue with shortcuts, in the start menu and taskbar, a few releases ago due to an issue in the Squirrel.Windows installer we use.

At this stage I can only suggest removing the shortcut, then uninstalling Sourcetree and re-installing. That should create new shortcuts which you can pin to the start menu,

Not interested in uninstalling, reinstalling and reconfiguring all my settings and keys.

Like Jasper van Santen likes this
minnsey Atlassian Team Jan 18, 2018

potentially unpinning and then re-running the full installer, rather than uninstalling first, download from https://sourcetreeapp.com might allow you to re-pin with the icon without loosing any settings.

FWIW as most configuration is store in %localappdata%\Atlassian\Sourcetree* uninstalling the app, from %localappdata%\Sourcetree, will not delete your settings.

 

I can confirm un-pinning, re-running the full installer, then re-pinning fixes the icon (and all your SourceTree configs are retained). No need to completely uninstall and then re-install.

Hi Dominic,

Thank you for letting us know that fixed your issue.

If you'd like, you can submit it as a new answer below Suggest an answer and I can accept it as the correct solution. This will help future users with the issue.

Regards,

Shannon

I can also confirm that this worked for me. All good now.

0 votes

Sean,

Although Michael's answer is best, would you be able to set the icon manually?

I remember this being pretty straightforward in earlier releases of Windows, and although I'm not very familiar with the version you're using, I would recommend that if you want to avoid reinstalling.

Of course, reinstalling would ensure you have the most up-to-date icon, but this is another workaround.

Regards,

Shannon

Same here.

3.3.6 on Windows 10.

Uninstalled 3.2.6 then installed 3.3.6 (no upgrade was offered from 3.2.6 installation) - still no Icon

I've had to remove from task bar - just too annoying!

I'm seeing a similar problem since I upgraded to 3.3.6. I've tried deleting/uninstalling all the old versions of SourceTree, deleting my iconcache.db etc. Having reinstalled SourceTree 3.3.6 I get the following:

There are two source tree exes:

 C:\Users\{username}\AppData\Local\SourceTree\SourceTree.exe

 C:\Users\{username}\AppData\Local\SourceTree\app-3.3.6\SourceTree.exe

Both of these show as having the normal icon in explorer. If I pin either of these exe's to my start bar then the normal icon appears on start bar.

Having pinned one of these to start bar, if I launch from start bar or by running exe directly, SourceTree starts up and a new blank white icon appears on my start bar.

SourceTreeWhiteIcon.jpg

I had the same problem and this fixed it:

  1. right mouse click on the taskbar icon 
  2. right mouse click on the empty icon
  3. properties
  4. change icon
  5. an error pops up that it can't find it => OK
  6. then a browse for icon option appears
  7. give it the new location:
  8. %USERPROFILE%\AppData\Local\SourceTree\app-3.3.6\icons\Notification\SourceTree.ico
  9. => OK
Like diegoadrada likes this

why, oh why won't the fix this????? Do they even read these community posts?

It's fixed at last, refer to my comments added to https://jira.atlassian.com/browse/SRCTREEWIN-8376

Get version 3.3.9. It is finally fixed !

Refer to my comments against the following JIRA ticket, since it is not possible to just download or update in an "obvious" way (which itself is a separate discussion!!!)

https://jira.atlassian.com/browse/SRCTREEWIN-8376

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,125 views 0 11
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you