Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Source Authentication Stopped Working

Problem:

- Sourcetree has stopped authenticating with GitHub. I cannot push, pull, etc.

- If I try to push/pull, one of 3 various username/password dialogs appear.

- Full output shows:

git -c diff.mnemonicprefix=false -c core.quotepath=false fetch origin

Logon failed, use ctrl+c to cancel basic credential prompt.
remote: Invalid username or password.
fatal: Authentication failed for 'https://github.com/...'

 

What did I do before this started:

- Source Tree: No changes to SourceTree were done by me. I pushed a change this morning and all was fine. This afternoon, any push/pull prompts with the username/password dialog (which 3 different ones appear at different times).

- GitHub: No security changes, only pushes, pulls, issue edits, etc.

 

My Sourcetree Configuration:

- I was using OAuth authentication

- Was using System Git (according to Options dialog). I never use command-line git on this computer (I have Sourcetree :) )

 

What Have I Tried to Fix This:

- Tried "Refresh OAuth Token". That succeeds and the Options dialog says "Authentication OK". But push/pull still has same problem.

- Tried changing to "Basic" and then "Refresh Password". My GitHub account uses MFA, so I use a GitHub "Access Token" as my password. Using that here, the Options dialog says "Login failed. Authentication failed for GitHub with username...". That very same Access Token works fine using command-line Git on my Linux computer.

- Uninstalled Sourcetree & Git and reinstalled Sourcetree. During installation, I chose "Embedded Git". Problem continues.

My Computer Configuration

- Windows 10

- Sourcetree version: 2.4.8

2 answers

The problem is that SourceTree's embedded git client comes with git-crediential-manager v1.12, which no longer works now that Github has disabled TLS 1.1.  Until they update the embedded git package, you'll have to switch to a system git client with git-credential-manager v1.14, or manually replace git-credential-manager in your embedded git client with v1.14.  You can get the new version of git-credential-manager from Microsoft's Github page.  I just downloaded the ZIP and extracted it to C:\Users\USERNAME\AppData\Local\SourceTree-Settings\beta\git_local\mingw32\libexec\git-core, but your path my vary.

The suggestion from Andrew worked for me.

Note: My path was a slightly different:

C:\Users\USERNAME\AppData\Local\Atlassian\SourceTree\git_local\mingw32\libexec\git-core

Having SourceTree use System Git also worked with the latest git install from:

https://git-scm.com/downloads

Thanks Andrew!

The solution worked for me.

Thanks Andrew.

I ran into this today. In my case, creating a Personal Access Token on GitHub and using that as my password instead of my actual password solved the problem. (I think this is necessary when you use two-factor authentication.)

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,419 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you