Sorucetree/Git-flow not merging branches properly

I have been facing a weird issue with my SourceTree installation over the last several months.  Out of my team, only mine seems to be behaving this way but a complete reinstall of SourceTree 1.6 and even updating to the latest version of SourceTree has not resolved the issue.

Some background information:

SourceTree Version: 1.8.3.0

Embedded Git Version: 2.7.4

Git-lfs Version: 1.1.1

Embedded Mercurial Version: 3.2.3

 

Git-Flow: Yes

Git-Flow Settings:

[gitflow "branch"]
master = master
develop = develop
[gitflow "prefix"]
feature = feature/
release = release/
hotfix = hotfix/
support = support/
versiontag =

 

OS: Windows 7 64-bit

 

Now for the problem.  When ever I finish a feature and then push that feature to our Develop branch, my SourceTree completes with errors and also fails to create a merge commit.  In addition my commits appear as though they were done directly on the Develop branch, the historical chart for all of my feature commits is flat.

Some screen shots for examples:

 

This is a screen shot of the error I am seeing on pushing a finished feature to our Develop branch:

st_11_scrubbed.png

 

This is how the historical graph looks after the push to the Develop branch.  Note that the third commit is a 'Merge branch' commit.  This commit was made by a colleague yesterday, the two most recent commits are both mine.  Each had a feature created for it but when it is finished and pushed it looks as if SourceTree/Git-Flow did not properly execute. 

st_12_scrubbed.png

 

I have had the main Atlassian know-alls on my team examine the issue and they also could not figure out why this was happening.  I have tried reinstallations of 1.6.4 and a completely fresh install of 1.8.3.  This still continues to happen.

 

Does anyone have any ideas?

2 answers

Have you modified your embedded git installation to use a different git-flow plugin than the one that is built in? The reason I ask is that the plugin included by default is the original gitflow, which does not include "support/" workflows. 

There is an old feature request trying to get Atlassian to replace the no-longer-supported nvie gitflow with the avh fork, which you may have installed: https://jira.atlassian.com/browse/SRCTREEWIN-1394

No, I have not but I don't know if the Bitbucket leads have done something so that a different version of git-flow is installed or not .  To be sure though I just spent the better part of today reinstalling SourceTree (had some issues uninstalling an old local Git installation) and cleared out the appdata as well.  Did a fresh install and when I ran git-flow for the first time and watch the console log I saw it create the Support workflow.

Still facing the same issue as in the op.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

647 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you