Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,455,372
Community Members
 
Community Events
175
Community Groups

Smudge error from git LFS when pulling in Sourcetree

Hi

We're currently unable to pull from our bitbucket repo because we're getting an error when Sourcetree calls git-lfs filter-process.

The file OID it claims it can't download is clearly visible in the LFS files section of the repo's settings and if I manually download it by clicking on the arrow next to its OID then rename it the file seems to be fine.

Running the git commands which are shown when choosing the "find local references" causes the following output:

$ git log -p --all -S fd365de7ea55b95a3fc9f0e23939fa3fc4779fb33b5b64edac75b93878 f06325
commit b3fe4c9c3fab772610b97b29346219365a2ae8b9
Author: XXXXX
Date: Sun Feb 17 23:23:51 2019 +0000
added dirt parameters to player car windows
diff --git a/RoadTrip/Assets/RoadTrip/Meshes/Vehicles/vehi_PlayerCar01.fbx b/RoadTrip/Assets/RoadTrip/Meshes/Vehicles/vehi_PlayerCar01.fbx
index 9a115bb..587c111 100644

--- a/RoadTrip/Assets/RoadTrip/Meshes/Vehicles/vehi_PlayerCar01.fbx
+++ b/RoadTrip/Assets/RoadTrip/Meshes/Vehicles/vehi_PlayerCar01.fbx
@@ -1,3 +1,3 @@
version https://git-lfs.github.com/spec/v1
-oid sha256:372221a0e53ca8fec7b000ac61c254b5dd50cd49bfe9c4ead57ce93093d77dc3
-size 3839200
+oid sha256:fd365de7ea55b95a3fc9f0e23939fa3fc4779fb33b5b64edac75b93878f06325
+size 3839360

I tried updating to the latest version of Sourcetree, and the latest embedded git / git LFS and it still gives the same error. I have also tried it both with and without "Enable the Bitbucket LFS MEdia Adapter" checked and I get the same result.

I use SSH but most other people on the project use HTTPS.

Here's the latest log log with smudge error

What workarounds are there for this situation?

e.g. is it possible to:
roll back the LFS link on the server's repo?
find out why it's not downloading?
pull everything except the problem problem file then replace it in a merge so I can keep working?

1 answer

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events