Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
badges earned

Your Points Tracker
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SSH not working on SourceTree?

I have set up SourceTree to use SSH but it does not appear to be working.
Whenever I try to do a fetch from our remote repository, I get prompted for a username and password.
When I enter the correct username and password, this is what I get (in the space marked XXXX, SourceTree puts my ACTUAL PASSWORD):

git -c diff.mnemonicprefix=false -c core.quotepath=false fetch --prune origin
Access denied
Access denied
Access denied
Access denied
FATAL ERROR: Server sent disconnect message
type 2 (protocol error):
"Too many authentication failures for XXXXXXXX"
fatal: The remote end hung up unexpectedly
Completed with errors, see above.

So not only does the SSH auth not work, I can't even use username/password auth. Does anybody have any ideas?

5 answers

1 accepted

17 votes
Answer accepted

I was able to fix the problem by changing from "Putty/Plink" SSH to "OpenSSH" for the SSH provider. No idea why this helped, but it works now.

I had this problem for days and spent many hours on it.... And this solved it!!!! Do this!



Like Gaurav Singh likes this

Thanks, i also had the same problem for days and today with your guidance i was able to fix it!

Wiser words have never been spoken. Thanks. This works

Wooooow, this answer is priceless.

It still does the job in 2019. Awesome and thank you!

God, this issue cost me around 3 days to find out.


This one worked for me as well. Thank you!


Can you please tell me the path?

I am still facing the same issue

Hi Tom,

This is very unusual behaviour. The error you're seeing which is showing your password is output from Git itself. Could you tell me more about your SSH setup? You've set up your id_rsa and keys in ~/.ssh/ and the URL for that repository has an SSH URL format? It looks like to me it's prompting for auth because it can't find any which could mean a number of things.

With further information we'll gladly be able to help.


I see the same problem when trying to use putty without keys (only username and password).

Please try with today's release (1.2.3), a couple of refinements have been added for URLs which don't include the user name and manual login is used.

Works now, thanks!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,376 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you