Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

SSH-key i tried to add into bitbucket repo


I tried again to clone on of my private repository.

it does not work this time.

my key is not valid or nonexistent.

I searched for and added a private key on the hard disk.

i addet my private key to SourceTree (private.ppk).

while start cloning one of my repo i got errors.

then inside prophertiey i pasteed the source of this key into the add key dialog.

it says: this key is invalid


funnily enough, but the up and download of another private repository works which also created at the beginning of this year in bitbucket. How is that possible?


here i did a video capure of my last try:



2019-03-27 09_16_58-Sourcetree.png


2019-03-27 09_20_04-Table awaiting Action.png



2019-03-27 09_27_19-Table awaiting Action.png


the problem stays 



2019-03-27 09_22_10-Table awaiting Action.png


3 answers

I was able to generate a public key in another way that has been accepted by bitbucket website.

means not with this tools overed from you in the tray menue.

means used command line window.

then i used some other tool to import. 

please make some changes regarding usability. thanks

0 votes
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Mar 27, 2019

It looks like the key you are trying to add might be in the wrong format?

Have you tried creating a new test key using the  instructions here?

yes I have created a new one today too. I left the default settings as they are. then I inserted the content of the private key per copy paste in bitbucket. and I get into the same problems

same problem now with the public key.

Comment: "rsa-key-20190328"
bla fo ....


same errors as i showed above insode bitbucket web interface.

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events