Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,369,340
Community Members
 
Community Events
168
Community Groups

Running script via custom action on Source Tree Windows

I didn't get it on working

image2015-1-23 17:0:14.png

image2015-1-23 17:0:59.png

the Script file works correct when i start it over the Windows command promt.

Oli

6 answers

1 accepted

0 votes
Answer accepted
Seth Rising Star Jan 26, 2015

I am guessing the problem here is that .sh files are not directly supported by Windows (.bat files are).

When you run that from the command line, is that a standard command line window, or one that's running cygwin? Try putting a specific command to run the file in front of it, like "sh start_project.sh ...".

Cool thanks it works i changed my "Custom Action" into

image2015-1-26 16:35:24.png

and now it works...

I can launch .sh scripts by using the full path in a bat file. So the work around for me was a bat file like this

C:\<Pathtoyourscripit>\PruneTags.sh

Hello,

I'am learning about git and sourcetree, I tried to make a custom action to send the command plotgitsch -ifirefox to see the imaging diff about kicad shematic.

Could you tell me more how to create the script and how can I link this script with the custom action..

I tried this on command bash it works fine, but when I define the custom actions it is not working.Working bash.PNG

sourcetree fail1.PNG

Could you help me please?

Thanks a lot.

Maxime.

No the Script isn't doing anything. Is seems to be that sc scripts doesn't work with Source tree for Windows or I'am doing something fundamentally wrong. So I also tried other scripts and got the same result.

0 votes
Seth Rising Star Jan 23, 2015

Is it possible that the script is doing what it is supposed to, but returning some sort of error code that you can't see when executing directly from the command line?

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events