Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,301,516
Community Members
 
Community Events
165
Community Groups

Repository does not exist after 3.3.9 Update.

Edited

Hi, I'm using SourceTree and Bitbucket, after updating sourcetree there's now a red ! on the repository button, I cannot push to the repository, and if I press it it takes me to the proper bitbucket page except there's an endless loading screen. If I simply go to the URL in the browser everything loads/logs in just fine that way, but that doesn't help with sourcetree. 

Every time "Repository: [] does not exist" is printed to the log sourcetree hangs for minutes and eventually has to be forced closed.

Reinstalling did not fix the issue.

The sourcetree log file after the update looks like this:
ERROR [2020-08-23 18:30:59,699] [1] [Sourcetree.Installer.Squirrel.Utils.UpdateHelper] [Log] - Couldn't read staging user ID
ERROR [2020-08-23 18:30:59,706] [1] [Sourcetree.Installer.Squirrel.Utils.UpdateHelper] [Log] - Couldn't read staging user ID
ERROR [2020-08-23 18:31:21,231] [1] [SourceTree.Model.Repository] [Log] - Repository: [] does not exist
ERROR [2020-08-23 18:32:00,647] [1] [SourceTree.Model.Repository] [Log] - Repository: [] does not exist
ERROR [2020-08-23 18:35:02,754] [1] [SourceTree.Model.Repository] [Log] - Repository: [] does not exist
ERROR [2020-08-23 18:38:02,519] [1] [SourceTree.Model.Repository] [Log] - Repository: [] does not exist
ERROR [2020-08-23 18:50:53,928] [1] [SourceTree.Model.Repository] [Log] - Repository: [] does not exist
ERROR [2020-08-23 19:05:55,452] [1] [SourceTree.Model.Repository] [Log] - Repository: [] does not exist
ERROR [2020-08-23 19:06:46,784] [1] [SourceTree.Model.Repository] [Log] - Repository: [] does not exist
ERROR [2020-08-23 19:10:21,108] [1] [SourceTree.Model.Repository] [Log] - Repository: [] does not exist
ERROR [2020-08-23 19:23:18,085] [38] [SourceTree.Exceptions.RemoteHostException] [Log] - Insufficient authentication credentials
ERROR [2020-08-23 19:23:18,138] [1] [SourceTree.Exceptions.RemoteHostException] [Log] - Failed to check login for user [mrpresidentjpk]
ERROR [2020-08-23 19:24:42,985] [PriorityScheduler: 1] [SourceTree.Scheduler.SourceTreeDispatcher] [Log] - Unable to get Dispatcher Application.Current is null
ERROR [2020-08-23 19:24:42,985] [PriorityScheduler: 1] [SourceTree.Scheduler.SourceTreeDispatcher] [Log] - Unable to invoke async action [System.Action] dispatcher is null
ERROR [2020-08-23 19:24:48,703] [1] [SourceTree.Model.Repository] [Log] - Repository: [] does not exist
ERROR [2020-08-23 19:27:57,103] [1] [SourceTree.Model.Repository] [Log] - Repository: [] does not exist

3 answers

1 accepted

1 vote
Answer accepted

I have the same red "!" issue and here is how I solve it (not once for all but each time I run sourcetree).

My version of sourcetree is 3.3.9.

1- Click on the Parameters button (third right of the button with the red "!").

Effect : Depot parameters panel opens.

2- All further steps take place in this panel (and one sub-panel):

2.1- Select "Distants".

2.2- Choose the origin depot for your project.

2.3- Click "Edit".

2.4- Choose the appropriate remote account for your project (I have several, you may just have your bitbucket accound AND a generic one, selected by default, which causes the red "!", as far as I understand).

2.5- Click "OK" to validate the remote account you selected.

2.6- Click "OK" to close the Depot parameters panel.

There, the red "!" should have disappeared...

This has worked for me for a week now, thanks.

I don't know why I have to go through a multi-step login process every single time I start sourcetree, but it has fixed the freezing issue and the red '!'.

Good to know it solved your issue.

Now, if you ever encounter a freezing issue again with SourceTree and think or re-installing.

You may wish, before re-installing SourceTree, to delete your local app data; beware, this action will destroy most, if not all, your SourceTree settings: you'll have to reconfigure SourceTree.

The folder for such data is hidden and you first need to make it visible: in Windows Explorer, click on the view tab (far-right tab at the top of the window) and then click on "Show hidden files".

Now folder "AppData" should be visible from your user folder; open "AppData" and go to "Local\Atlassian" : there, violently delete all the SourceTree folders before re-installing.

You'll lose your settings, but thus SourceTree will be forced to start anything new and thus shouldn't freeze anymore.

Same issue here with 3.4.6

ERROR [2021-10-01 09:06:59,282] [1] [SourceTree.Model.Repository] [Log] - Repository: [] does not exist

When attempting to clone a repo - it fetches remote Url and details (identifying it as a Git repo) then in the next phase with the circular spinner to the right of the 'advanced options' dropdown... it then crashes without error or warnings (just closes app)

Was working fine for weeks and this (for me) started 2 days ago, without any config changes - or any changes to SourceTree at all (I just tried opening a different repo from the same account in DevOps)

Authentication is fine (I'm using a PAT which it accepts, and it appears to find the repo in the first lookup step (setting repo options to Git etc) and as I say, its in the 2nd lookup phase where it retrieves info about the  where it then dies

I have the same issue.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Bug Fix: Sourcetree for Windows authentication error when updating to app password

Hello Sourcetree users!!! With the recent removal of Bitbucket Cloud account passwords for app passwords (please see our Bitbucket Cloud community post for details on why we made this change for se...

63,026 views 128 27
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you