It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Registering bitbucket account failed

I am trying to set up source tree and connect to my bitbucket account.

I am using https://bitbucket.org as the root url and Andrew_Watkins as the username.

I get this error after I enter my password: "Failed to check login for user [Andrew_Watkins]: the URL 'https://bitbucket.org/rest/api/1.0/users/Andrew_Watkins' returned code 'NotFound'."

Any suggestions to resolve this are welcome.

Also, I can access my bitbucket account directly without issue.

 

Thank you,

Andrew

3 answers

1 accepted

3 votes
Answer accepted

Could it be that you selected 'bitbucket server' instead of 'atlassian account?' in the step before?

The bitbucket server option is for when you install your own server, not when you use the bitbucket.com server. 

Source: I encountered the same problem just now.

Yes, that is what I had mistakenly done - thanks for the help!

uuuh, that is the solution. Thanks Hendrik !

It is a bit confusing 

1 vote
Ana Retamal Atlassian Team Apr 23, 2018

Hi Andrew, the URL https://bitbucket.org/rest/api/1.0/users/Andrew_Watkins is not a valid one. When it asks you for the URL you should enter https://bitbucket.org/Andrew_Watkins.

Also, have you followed the steps at Get started with Sourcetree to connect Sourcetree to your Bitbucket account? 

Let us know how it goes!

Best regards,

Ana

Hi Ana.  I have the same issue.  Unfortunately, your suggestion didn't work.  Also, I can't even get started with Sourcetree since I can't get past the initial setup where it asks for the login server and user name.  Like Andrew, I am able to directly login to bitbucket just fine.

Thanks,

Paul

Hi Paul,

I linked the Atlassian account instead of bitbucket server and was able to install source tree. I had to go through the process on linking the Atlassian account multiple times before the process was successful.

Hope that helps.

Thank you,

Andrew

Yes, I had the same experience - thanks for the help.

Paul

Hi, I am unable to install Sourcetree too. I selected Bitbucket during installation, my Root URL is: https://bitbucket.org/mvanicky, my Username is mvanicky. Error I got is: Failed to check login for user [mvanicky]. The URL 'https://bitbucket.org/mvanicky/rest/api/1.0/users/mvanicky' returned code 'NotFound'.

Ana Retamal Atlassian Team Jul 10, 2018

Hi @Miroslav Vanický, my guess is that you're referring to the registration options that we offer at the beginning while you're installing Sourcetree, that are using either your Atlassian account or your Bitbucket Server account. If that's the case, it is failing because you're entering your Bitbucket Cloud account, which is not an option. You will need to use your Atlassian account instead (note that your Atlassian account uses the same credentials as your Bitbucket Cloud account).

If this is not your case, please send us a screenshot of where you're stuck and we'll be happy to continue helping you.

Kind regards!

Ana

Thank You, what should I do now? I am little confused.

I selected Atlassian instead of Bitbucket and then it worked. Thank You. The core is: "your Atlassian account uses the same credentials as your Bitbucket Cloud account"

Ana Retamal Atlassian Team Jul 11, 2018

Hi Miroslav, glad you were able to proceed :) 

Have a good day!

Ana

this is the most confusing login ever. I should select atlassian login to use my bitbucket creds??? 
can't imagine the person who did this login screen... 

Ana Retamal Atlassian Team Jul 11, 2018

Hi @Margus, our Cloud products use Single Sign On, which means they all use the same set of credentials. So yes, your Atlassian account credentials are the same as your Bitbucket account credentials, I wanted to make this extra clear for the users that are still not familiar with it and might have trouble remembering which password they used.

However, you don't necessarily need to have a Bitbucket Cloud account to use Sourcetree (you can be using Github or any other service), and that's why the 'Atlassian account' option is there. So again, yes, the person who did this login screen thought about the different possibilities our users have. 

Hope this makes sense to you.

Best regards,

Ana

I must agree that this is confusing. Maybee little more of explanation in the setup process/windows would by nice.

For me, when I select Bitbucket Cloud, the single sign on URL just goes into an infinite loop in Chrome and never returns (also on a Mac). This works fine on my other Mac. Not sure what's going on, but I can't get past the initial registration screen. 

thanks all - my rego is now complete - phew!!!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,970 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you