It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Registering Sourcetree - Login to Bitbucket account not working

Hi, I'm trying to install Sourcetree and getting stuck on the registration step.  When prompted to pick between Bitbucket Server and Bitbucket, I'm selecting Bitbucket, which sends me off to the Bitbucket website.  I then sign in there without any problems, I get asked to confirm access to my account and then when I click "Grant access" it fails - in Chrome i get a message saying "This site can't provide a secure connection", similar in IE.  Sourcetree itself just sits there "waiting for login to finish".  

I've tried this in both Chrome and IE, and I've tried with a couple of different wifi networks just in case there's anything getting blocked or whatever, and I've even tried creating a new account from scratch just in case something's wrong there, but that hasn't helped either.

Any ideas on how I can resolve this issue?

1 answer

1 accepted

2 votes
Answer accepted
Ana Retamal Atlassian Team Jan 23, 2019

Hi Nick, welcome to the Community!

Can you check if Internet Explorer is updated to the latest version? (We've seen issues with the authentication caused by older versions). If it's updated and still not working, please try the following:

  • Turn off compatibility mode in IE. To do that, open Internet Explorer, go to the Advanced options tab and click on Reset your Internet Explorer Settings
  • Check Delete personal settings
  • Change your Internet Explorer Security Zone Settings:
  1. Open IE, click on the gear and select "Internet Options"
  2. Select the "Security" tab
  3. Select "Custom Level" for Internet
  4. Find "Access data sources across domains" and select "Enable" (make note of what the setting currently is)
  5. Try logging into Sourcetree again

After logging in, follow steps 1-4, but reset the setting back to the previous option.

If the above fails, can you also check the log and see if it provides any further information?You can find it at C:\Users\<username>\AppData\Local\Atlassian\SourceTree\sourcetree.log.

Cheers!

Ana

Thanks for this Ana, the first solution of resetting my IE settings seems to have done the trick, all up and running now!

Ana Retamal Atlassian Team Jan 24, 2019

Woohoo! Glad to hear that :D 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,995 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you