Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,734
Community Members
 
Community Events
176
Community Groups

Registering Sourcetree - Login to Bitbucket account not working

Hi, I'm trying to install Sourcetree and getting stuck on the registration step.  When prompted to pick between Bitbucket Server and Bitbucket, I'm selecting Bitbucket, which sends me off to the Bitbucket website.  I then sign in there without any problems, I get asked to confirm access to my account and then when I click "Grant access" it fails - in Chrome i get a message saying "This site can't provide a secure connection", similar in IE.  Sourcetree itself just sits there "waiting for login to finish".  

I've tried this in both Chrome and IE, and I've tried with a couple of different wifi networks just in case there's anything getting blocked or whatever, and I've even tried creating a new account from scratch just in case something's wrong there, but that hasn't helped either.

Any ideas on how I can resolve this issue?

1 answer

1 accepted

2 votes
Answer accepted
Ana Retamal Atlassian Team Jan 23, 2019

Hi Nick, welcome to the Community!

Can you check if Internet Explorer is updated to the latest version? (We've seen issues with the authentication caused by older versions). If it's updated and still not working, please try the following:

  • Turn off compatibility mode in IE. To do that, open Internet Explorer, go to the Advanced options tab and click on Reset your Internet Explorer Settings
  • Check Delete personal settings
  • Change your Internet Explorer Security Zone Settings:
  1. Open IE, click on the gear and select "Internet Options"
  2. Select the "Security" tab
  3. Select "Custom Level" for Internet
  4. Find "Access data sources across domains" and select "Enable" (make note of what the setting currently is)
  5. Try logging into Sourcetree again

After logging in, follow steps 1-4, but reset the setting back to the previous option.

If the above fails, can you also check the log and see if it provides any further information?You can find it at C:\Users\<username>\AppData\Local\Atlassian\SourceTree\sourcetree.log.

Cheers!

Ana

Thanks for this Ana, the first solution of resetting my IE settings seems to have done the trick, all up and running now!

Ana Retamal Atlassian Team Jan 24, 2019

Woohoo! Glad to hear that :D 

Actually today when I tried to install sourcetree, I also faced the same problem. I followed the method suggested but after that too the problem persists.
Kindly help.

Thanks1.jpg 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events