Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,365,749
Community Members
 
Community Events
168
Community Groups

Red Exclamation Mark on Remote Icon

Everything seems to be working fine (i.e. I can commit and push changes), but I have a red exclamation mark on the remote icon. Presuming there's an error I click on it and it opens my Github repository in a browser window - I don't see an error so not sure why it's displaying - can anybody help please?

 

14 answers

Facing the same issue here. Did anyone come up with a solution for this ?

 

Solution-

If all the push, pull, commits are working but still there is a red exclamation mark on the remote icon and on clicking it you are just redirected to your bit bucket account then the following step can be followed to get rid of the error.

Open Repository from Menu Bar -> Click on Repository Settings -> Edit the origin -> Copy the Remote Origin URL into clipboard -> Remove the origin and paste it again -> Click on Ok.

This somehow refreshes the previous connection and gets rid of the Red Exclamation Mark

PS: Other than the above issue, after updating to 3.3.4 I was also getting invalid credentials error which was fixed by deleting the 'passwd' file in 'C:\Users\<username>\AppData\Local\Atlassian\SourceTree', restarting source tree and entering the credentials while doing a git pull/fetch for connectivity test.

While that worked for me at first, turned out it came back when I closed and re-opened the app. It doesn't seem to keep the correct Remote Account selected in the Repository Settings. Every time I re-start the app, the exclamation point comes back and the "Generic" account is selected. When I set it to my actual remote account the exclamation mark goes away.

Like # people like this

Doing the 'null update' thing works for me as well (until the app is restarted and breaks itself again).

Same issue here. I can pull/push/fetch without issues and click the remote link and go to my repo. I also routinely get the askpass.exe pop-up error "the application was unable to start correctly" which I feel may be related.

Capture.JPG

I also get the Askpass.exe "The application was unable to start correctly" message.

Clicking OK dismisses it, but another opens immediately.

This is continuing, even though I have closed SourceTree.

Any ideas?

Diavel, thank you! it works for me. Copy and remove origin works like charm!

Worked for me ... thanks ..

Yes, copy and paste worked for me. After restarting the computer, it's still OK.

Nov 2/21. Worked ok.

What solved me is that when I changed remote account from Generic Account to my GitHub account at the Account in the Repository / Repository Settings.

This worked for me also.
Repository / Repository Settings, click the Remote repository path, then click Edit, then in "Optional extended integration" change from Generic Account to your account (in my case was Bitbucket).

Like # people like this

to me, even if I follow your suggestion, the exclamation mark keeps returning after a restart... (SourceTree 3.3.8)

Like # people like this

Changing the account does work, but it doesn't save that account when closing the app. Every time I reopen the application it resets to the default account.

Like # people like this

Worked like charm, Thank you

Been there, done that. As soon as you exit the app and reenter, it breaks again

Like # people like this

It worked like a charm! 
Thanks

This worked for me as well. Thanks!

Worked for me as well

Worked, thanks a lot (= !!!

Somehow the bookmarks were causing this for me. If you go to View -> Toggle Bookmarks Sidebar and delete the bookmark for the repo in question, then restart sourcetree it should be gone.

If you add the bookmark back it will come back. Maybe it works for others.

This worked for me, thank you!

Like Wiktor Mołoń likes this

Works even after restarting!! Thanks a lot!

This one works. Thanks you !

This also worked for me - thanks!

This did not work for me.

Works for me. Thank you!

Hi,

I have the same problem with 3.3.8 version.

Reinstalling not resolve the problem.


:(

I had the same problem since 3.3.8. 

Repasting the URL (as per the above answer) didn't work, but I found that on the same screen as the URL the 'Host Type' in the bottom part of the screen was 'unknown'. Changing that to something else made the exclamation go away. (I used Bitbucket)

The section is labelled up as 'Optional extended integration' and then 'Legacy Account Settings' and I am not using it... however changing that host type caused the exclamation to go away, setting it back to unknown caused the exclamation to come back.

Everything seems to be working either way I set it, so I'm leaving it set.

Like # people like this
Like # people like this

Also confirming that this problem exists on a fresh install of 3.3.8.  Setting the BitBucket repository as origin/default and selecting the BitBucket account temporarily resolves it, but as soon as I close and re-open, the account is set back to Generic and the problem returns.  Likewise, for Generic accounts for GitHub, the GitHub user account is cleared.

This happened to me since 3.something and continued up till 3.4.4, today. That tip from @Rosie.Coller solvedthe issue for me. Went from "Unknown" to "BitBucket" and got a completely incorrect host URL setup for me as mandatory value but since the actual Git URL is still in place it seems to not make a difference. At least now the irritating red exclamation is gone. Thanks a lot, Rosie. That thing was super annoying!

@"ATLASSIAN" Is it possible for you to say when this will be fixed or will it be fixed?

RedExclamationMark.jpg

I believe this is the ticket to get this issue fixed:
https://jira.atlassian.com/browse/SRCTREE-6139

Reinstalling Source Tree fixed this issue for me. 

Thank you for your post. Just spent at least 1 hour trying to solve the exclamation mark. I used version 3.3.4. So I downloaded new SourceTreeSetup - and it's 3.3.6. And all issues magically disappeared.

Not sure why the latest version wasn't offered for upgrade automatically. But I am happy the annoying exclamation mark went away.

Like Tom Schulte likes this

Worked for me, too. Also saw that 3.3.4 claimed it was the latest and reported no update available even when doing an explicit "Check for Updates"

Like Steve Melnikoff likes this
0 votes

May be this is because of the Account issue {^_^}

To fix this follow this flow, its worked for me :

  1. Go to settings:1.png
  2. choose the origin(the the git path is correct) and Click "Edit"2.png
  3. Change the "Generic account" to your repository account(the gitHub account which has the repository) and click ok.3.png

After a little testing with my 10+ repositories, I found the difference between repositories that had an exclamation mark and ones that did not is that the ones with no mark had the user name filled in. I added the remote URL to a couple but then saw that it really just wanted the user name. I left those ones as generic with the user name as they are working fine.

I have same problem I don't know why sourcetree don't verify periodically any info needed from remote.

Other thing user icon in local is different respect github user icon .... It's strange that sourcetree before to push don't get any info needed to be aligned. This is a process bug in different action that offers to users...

Reinstall sourcetree is a lost of time this feature must be a process step before to push. User never need to reinstall application. I have a lot of users in different git services... You image that anytime reinstall sourcetree ? It's a stupid solution...

Scroll up. @Rosie.Coller  gave a working solution above. MY red dot was there for months before I saw this... then poof... gone ever since! 

We use the Sourcetree 3.3.9 Enterprise MSI version and face the same problem. Just opened a ticket here because when checking out from the local Bitbucket Server instance and the extended repository details are not correct the client also crashes. The symptoms could be easily fixed by switchung to the authenticated local Bitbucket Server account - but these changes are not persisted as described here: https://jira.atlassian.com/browse/SRCTREEWIN-13256

switched to gitkraken, far more reliable, bye sourcetree

I'll try it too, thank you!

Like Jacob Hansen likes this

I had this issue last week, and found this page - problem solved.
Had the same issue, with another project, this week - no dice.

@rarmourDo you have a link? ;)

Unfortunately not, as it's a private repo

Hi Rosie

I test your solution.

I switch Host Type from Bitbucket to unknown and unknown to Bitbucket and the exclamation go away. But if I restart it the exclamation come back.

I try to put the sourcetreeconfig.json file in .git folder on READ ONLY but Sourcetree use Generic account every restart.

I think you must have a different cause to me then. Mine was originally set to Unknown and I changed it to Bitbucket and left it as that. the exclamation then went away and stayed away.

Lucky. I switch to 3.1.2 version and no more problem 

If you change to Bitbucket then that Remote icon when clicked goes to Bitbucket. It gets pissy if you have unknown which is wrong. I submitted a bug

I have 3.3.8 and I'm seeing the exclamation point, too - but not because the repo type is unknown.  My repo type setting was GitHub.

A couple of things:

1) editing the entry and then saving does make the exclamation go away but it comes back after restart

2) The type GitHub seems to expect/imply the host name on the url to be www.github.com but the www. part appears to be optional.

3) Clicking on the Remote icon always seems to get me a 404, whether the url says www.github.com or github.com - yet the operations for the branch seem to be working.

Like Steve Melnikoff likes this

i am having same issue

Did you find solution?

Like # people like this

The same for me.

Same issue. Change Repository->Repository Settings -> Edit -> Host Type: (fill in settings) makes the red exclamation point go away, until exit and restart source tree view.

Like # people like this

Exactly the same behavior with Sourcetree 3.3.9 - the extended repository details are not persisted when Sourcetree is restarted. Issue: https://jira.atlassian.com/browse/SRCTREEWIN-13256

Like baluditor likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events