Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Rebase/stash not working after enabling GPG signing

I've enabled GPG commit signing on the command line, and manually enabled via the "Repository Settings" section of SourceTree for each repo:

Screen Shot 2016-04-11 at 15.12.48.png

If I manually select "Sign commit" each time SourceTree correctly signs my commits:

Screen Shot 2016-04-11 at 15.16.48.png

However any other operation like stash or rebase doesn't seem to include the GPG options in the command and I get the following "gpg: cannot open `/dev/tty': Device not configured" error:

Screen Shot 2016-04-11 at 15.18.41.png

I see you even have a support article about this, but the proposed solution is enabling GPG signing in SourceTree which I've already done.

5 answers

git config --global gpg.program gpg2

This maybe your answer.

Thanks for your answer Aditya, I'm afraid I already have this set in my config though.

this did the trick for me, thanks!

Remove the gpgsign attribute in the [commit] section of your .gitconfig if it's there.

This solved it for me.

Won't that just disable GPG signing of commits by default? I'd like to keep this on, and think SourceTree should respect it.

I have to manually select "Sign Commit" in SourceTree anyways, even with the attribute enabled.

So I think it only takes effect for commits done via Terminal. Have you restarted SourceTree after modifying the config?

I have, and SourceTree doesn't respect this global git default. I'd rather not remove this since I want all commits to be signed - SourceTree should improve its GPG support.

Absolutely, it would make more sense for them to enhance the software to respect the standards.

Honestly, I've stopped using stashes because of this issue, which is really annoying :-/ The workaround I proposed above is NOT viable at all.

Please Atlassian, make SourceTree work better with GPG!

edit: Check this out, worked perfectly for me!
https://answers.atlassian.com/questions/38060409/answers/38398747

@Armando Lüscher thank you for finding that and letting me know!!

I'm having the same issue.

Disabling the key signing for the repository also doesn't help, I can't stash anything any more!

 

Any news on this?

Nope, I'm still having this issue. Please upvote/share to get it noticed!

I confirm that I am having same issue with rebasing.

+1

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Sourcetree

[dev team] Sourcetree for Windows 2019 Preview - Dark Theme

Hi folks, While the full post is over on our blog I'd like to share the dark theme we've got planned for 2019 here directly as well to keep the discussion going.  The ...

3,716 views 19 19
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you