Rebase/stash not working after enabling GPG signing

I've enabled GPG commit signing on the command line, and manually enabled via the "Repository Settings" section of SourceTree for each repo:

Screen Shot 2016-04-11 at 15.12.48.png

If I manually select "Sign commit" each time SourceTree correctly signs my commits:

Screen Shot 2016-04-11 at 15.16.48.png

However any other operation like stash or rebase doesn't seem to include the GPG options in the command and I get the following "gpg: cannot open `/dev/tty': Device not configured" error:

Screen Shot 2016-04-11 at 15.18.41.png

I see you even have a support article about this, but the proposed solution is enabling GPG signing in SourceTree which I've already done.

5 answers

Remove the gpgsign attribute in the [commit] section of your .gitconfig if it's there.

This solved it for me.

Won't that just disable GPG signing of commits by default? I'd like to keep this on, and think SourceTree should respect it.

I have to manually select "Sign Commit" in SourceTree anyways, even with the attribute enabled.

So I think it only takes effect for commits done via Terminal. Have you restarted SourceTree after modifying the config?

I have, and SourceTree doesn't respect this global git default. I'd rather not remove this since I want all commits to be signed - SourceTree should improve its GPG support.

Absolutely, it would make more sense for them to enhance the software to respect the standards.

Honestly, I've stopped using stashes because of this issue, which is really annoying :-/ The workaround I proposed above is NOT viable at all.

Please Atlassian, make SourceTree work better with GPG!

edit: Check this out, worked perfectly for me!
https://answers.atlassian.com/questions/38060409/answers/38398747

@Armando Lüscher thank you for finding that and letting me know!!

git config --global gpg.program gpg2

This maybe your answer.

Thanks for your answer Aditya, I'm afraid I already have this set in my config though.

I'm having the same issue.

Disabling the key signing for the repository also doesn't help, I can't stash anything any more!

 

Any news on this?

Nope, I'm still having this issue. Please upvote/share to get it noticed!

I confirm that I am having same issue with rebasing.

+1

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

765 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you