It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Pushing to remote: Forbidden fatal: unable to access URL The requested URL returned error: 403 Edited

I keep getting this 403 Forbidden error on Sourcetree while trying to push to remote repository:

 

Pushing to https://bitbucket.org/user/repo

remote: Forbidden

fatal: unable to access 'https://bitbucket.org/user/repo/': The requested URL returned error: 403

 I can successfully push from the command line. I have tried updating credentials in Sourcetree > Preferences > Accounts without success. Any help on this topic?

3 answers

1 accepted

9 votes
Answer accepted

I finally found a solution. Because I handle multiple accounts on Bitbucket, I had to change the repoistory URL to

https://user@bitbucket.org/user/repo

 This way Sourcetree prompts the password for the account specified in the URL.

How to change this url??

Like # people like this

ejemplo.JPG

Thank you, 

here you do that,

Can you tell me exactly how to go to that particular page/view you have posted?

Like # people like this

Please more explain.

Like 심민우 likes this

For anyone still wondering, on Source Tree go to Settings:

set1.PNG

Then Edit the origin:

set3.png

I have got the same problem but I have only one repository. please help me out

You might not have the write access to the repository

Like # people like this

Yes you tell your repository admin to give you the write access not the read access.

Like Birhan likes this

Nothing seems to be working. Got a single account, I can click the "Remote" button on Sourcetree and it navigates to the Bitbucket. But when pushing the changes, it throws 403 error. 

It was working till yesterday and nothing has changed since then. I also tried creating new app password and under Authentication it shows the green icon but still not able to commit the changes. 

I can access to bitbucket throug chrome but When I tried to clone project from bitbucket I had also this issue and I solve it with following code 

git config --global http.proxy http://proxi_ip_or_host:80

git config --global http.proxy http://127.0.0.1:8080

127.0.0.1 - you proxy ip 

after two dots : 8080 your port number

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,965 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you