It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Pushing requires password authentication

I am trying to push to the master branch on SourceTree and every time, it asks me for the account password. I type the right password but to no avail. I added an SSH key but it still will not fix the issue.

Can someone help?

1 answer

Chances are is that BitBucket is prompting for a captcha upon login.

Try logging out of BitBucket and then logging back in. Or if you are an admin, locate your user and clear the "Captcha required" for the user and re-attempt a push to BitBucket.

I do not have global permissions. I have a free account.

So in your case then, log out of bitbucket, then log back it. That will reset the captcha prompt allow you to submit code from sourcetree. If the password fails again then the captcha will be re-triggered.

I logged out then logged back in. I still get the same problem. I am prompted with a "Password Required" dialog box. 

I solved the problem by pushing with the terminal and it worked. Thank you for your help, I appreciate.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,917 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you