It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Push from sourcetree does not reach the website Edited

Hi everybody,

I'm having a odd error with my git and I wonder if someone can help me solve it. In short, the commits and pushes I have on my computer's Sourcetree do not match those on the online repo and can't be accessed by other computers. 

It started when, trying to make a large commit + push through Sourcetree, the loading bar seemed to have gotten stuck, even after I left it for several hours. The output log didn't show advances either.  I decided to cancel and see what was happening. However, when I canceled, sourcetree showed that the push had been successful and was in the repo. I left it at that but, in trying to clone the repo to another computer, I noticed that, online, that commit does not appear at all.  I have not received an error message of any kind.

I've tried making more pushes from the computer, but they have the same result.  When trying to use the command line, I get a message stating the repo is up to date.

I've updated sourcetree to the latest version, and am still finding this issue. Has anyone encountered it before? If so what can I do to solve it?

 

2 answers

1 accepted

Hey everybody, it seems it was all due to an authentification error. The solution here found by Brian was the one that worked for me:

 https://community.atlassian.com/t5/Sourcetree-questions/Getting-quot-fatal-Authentication-failed-for-quot-error/qaq-p/624663

 Just remember to delete the passwd file from the altassian folder while sourcetree is closed.

I'm leaving it here in case anyone encounters the same error.

 

Cheers!

Just more information: I tried again through the command line and, although it seems it is being slowly pushed, it keeps getting interrupted by password requests for the repo. Despite me placing the correct password over and over again, they just keep popping up. I'm not sure if this is related, but I thought I'd share anyway.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,907 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you