Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal


  • Give kudos
  • Received
  • Given


  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Push does not work since 3.2.5

I have recently upgraded to version 3.2.5.

Since then Push no longer works. The dialog does not display any branches.

Pull works.


11 answers

10 accepted

10 votes
Answer accepted

Based on a suggestion from another user:


I tried upgrading the Embedded Git used by SourceTree  

(Tools => Options => Git => Update Embedded Git)

And after that, my Push Dialog showed all the branches once again.


To avoid such problem in the future, SourceTree upgrade process should detect version of Embedded Git and notify user when the Embedded Git also needs to be updated 



However, there still appears to be problems with the Push Dialog:

  • create local branch
  • commit local, do not push to remote branch
  • Open Push Dialog



Push Dialog should show my recent local branch as available to push to remote



Push Dialog does not show my recently created local branch

The change to Git Version Embedded (2.21.0) has helped me.

This does indeed seem to work. I suspect even switching to the system git might do the trick.

@Phileo99  Just tried and it works perfectly! Thanks man.

Like Jens-Peter Frank likes this

It works now! Thanks @Phileo99 

"Update Embedded" crashed in the middle so 

I had to do Tools => Options => Git =>Git Version: Embedded

and download the whole thing  (2.21.0) and that solved everything

Like captaincaffeine likes this

Your solution doesn't work in my case and I had to fix downloading the Portable Git 2.21 and replace my version manually.

So If anyone doesn't fix by Source tree could browse the GitFolder and replace the local git version as I did.


4 votes
Answer accepted

I have exactly the same issue. A simple work around to this is by downgrading to an earlier version.

Please Atlassian, can somebody look into this ASAP!

4 votes
Answer accepted

In my case upgrading the embedded version of git solved the issue, but I had to switch to actually use the embedded version since I was using the system git at 2.13.1. Updating the system git also worked. So apparently you need to update to git >2.13.1

I can't reproduce the issue reported by @Phileo99 in his update, neither with the embedded git nor the system git. However when I click the local branch to push, it doesn't show the new branch name in the remote branch column like it used to do with earlier versions. The push works however, and after pushing, the name is shown on subsequent pushes.


This fixed the problem for me.

Thanks, @markchagers :)

1 vote
Answer accepted

I created a bug report almost two weeks ago 

I can't see the issue page. How is it being handled? Any progress or workaround (beside reverting to an older version)?

I found some related bug reports:


It looks like the entire push menu doesn't work correctly for some time. Initially, I no longer had auto-completion for remote names of untracked branches (3.2.5). Then, in 3.2.6, this happened.

1 vote
Answer accepted

I've got the same problem.

In case this is helpful: I added my repositories to SourceTree by adding existing folders in my HD, not by downloading the code from BitBucket (I already had them synchronized with a previous application)

0 votes
Answer accepted

Same issue! I've recently upgraded to 3.2.6.

How can I solve?

you have to downgrade to 3.1.2 or lower

0 votes
Answer accepted

I also have the same issue after updating to the lastest version of sourcetree (v326.3544). Could you please check?

Same issue. If you try to open "Terminal" and run "git push" it works.

A little workaround.

Like Gasalho Antero likes this

Thanks for you info, but it doesn't work for me. Using the terminal terminal does not consider my private key. Really strange. After downgrade to v3.1.3 everything is working again, also terminal


it works for me thanks :).

The issue still remains in Sourcetree

0 votes
Answer accepted

I'm really disappointed in SourceTree. Do you guys not do any testing in your release cycle?

0 votes
Answer accepted

I am experiencing the exact same problem, Push dialog shows empty branches.

Had to downgrade to version 3.1.2 to get back my branches to show in Push dialog.

Atlassian Please FIX, I did not agree to be your unpaid Beta tester !!!

0 votes
Answer accepted

I have exactly the same issue. This occurred sometime after the automatic update to 3.2.6, although it had been working fine for a few days after the update.

Pushing via the command line still works, and all of my remote branches appear, but no branches show up in the Push window. Fetching does nothing. The same problem affects all of my remote accounts, both on Bitbucket and GitHub.

Just updated to 3.3.9 and it still doesn't work. Hell, the Terminal menu doesn't work neither (I saw somebody mention this as a work around)

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted in Sourcetree

[dev team] Sourcetree for Windows 2019 Preview - Dark Theme

Hi folks, While the full post is over on our blog I'd like to share the dark theme we've got planned for 2019 here directly as well to keep the discussion going.  The ...

3,451 views 19 19
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you