Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,132
Community Members
 
Community Events
176
Community Groups

I always get a popup credential helper selector asking me to choose a credential helper

And it comes back even if I set "always choose this form now on" to true

6 answers

1 accepted

18 votes
Answer accepted

Same issue. Just installed the latest version of SourceTree (3.3.9) on a fresh build of Windows 10 v2004

git-credential-helper-selector_RRLCjHIiej.jpg

Open Windows Powershell (Admin) from the Start Button context menu:

y1dGIOaNgY.png

If it's not there, search for Windows PowerShell, click the > arrow and select Run as Administrator:

explorer_vukSGeNyph.png

Run the following commands (in bold) excluding the #comments:

#Navigate to the SourceTree LocalAppData folder

cd $env:LOCALAPPDATA\Atlassian\SourceTree\git_local\mingw32\bin\

OUTLOOK_FHQGzMemWK.png

#Run git.exe to edit the config file

./git.exe config --edit --system

powershell_mFOqHMHJEC.jpg

#This open a VI text editor

#Press the letter "I" on your keyboard to enter INSERT mode

OUTLOOK_eccuo57T1Q.png

#Update [credential] helper in the config file as shown in the screenshot above or below.

[credential]
helper = manager

#Press the "Esc" key on your keyboard until INSERT mode exits, then type :wq and press Enter. This "writes and quits" the VI Editor.

:wq

powershell_MX6nx0h1yE.jpg

Like # people like this

thx a lot :)

Like jbali sofien likes this

you just saved my day

Thanks a lot, it is helpful.

Worked for me!

What is meant by:

Esc

:wq

Hey @Leslie Johnson

Its a command to save and close in Vi editor.
you can use any text editor you are comfortable with such as notepad.

Like Leslie Johnson likes this

ok how to open config and change this settings 

 

To be clear - after you have edited it so:
[credential]
helper = manager

press 'Esc' button

type :wq and press 'return'

(for other VI newbies like me!)

Amazing guide, thank you

Like Ioham Leandro likes this

Thank you @Ollie CJ @dpreston31 :)

Like Ollie CJ likes this

on windows 11 it returns this error, i manually check the folder its there. Not sure whats wrong hre?

'''
%localappdata%\Atlassian\SourceTree\git_local\mingw32\bin\ : The module '%localappdata%' could not be loaded. For more
information, run 'Import-Module %localappdata%'.
At line:1 char:1
+ %localappdata%\Atlassian\SourceTree\git_local\mingw32\bin\
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : ObjectNotFound: (%localappdata%\...al\mingw32\bin\:String) [], CommandNotFoundException
+ FullyQualifiedErrorId : CouldNotAutoLoadModule
'''

Like Justin W_ likes this

The person who wrote this clearly assumes everyone knows what powershell is or how to use it.  The reason I use sourcetree is so I don't have to use command line things, so this 'help' is unhelpful and needs to be more explicit.

Like # people like this

i love u man you saved me !!!!!

tried everything, literally everything, nothing worked, saw this post by mistake, it worked like magic!

Like Justin W_ likes this

Thank you dude. This thing was getting annoying. 

I'm using the latest version, 3.4.7, under Windows 10.  Is this still an issue in that version?

Also, I'm brand new to Sourcetree and was hoping this kind of tool would keep me OUT of the command line.  If I spend all day, I MIGHT be able to get this done per the steps given.  Is there no other way to do this?  I cannot connect to my remote repo because of this error.

Worked for me !!! Thank you.

I finally got this working by following the exact steps with one modification:

[credential]
helper = manager-core

Like # people like this

"git log" failed with code 128: fatal: bad config line 1 in ... gitconfig.

Just installed sourcetree on a new windows machine (running windows 11) and encountered this issue. Following DTech's answer, but instead changing the "helper" assignment to manager-core instead of manager worked for me.

Hope this helps someone!

Like # people like this

In 2022, installing SourceTree in a new Windows 11 virtual machine still prompts me with this popup of the death... What a pathetic expercience for new users, such as a full class of students...

However, i found out that selecting "manager-core" from the list and checking always use was the solution. If the popup comes again, select the second option "manager-core" was definitive. I don't know why there are several options with the same name, but the second one was the solution.

Also since I was cloning a repository (with https) from bitbucket, I had to connect to my account in Tools > Options > Authentication > Add > select HTTPS and OAuth

Great work finding a simple solution, this helped, thanks!

Like # people like this

You are my savior. Thanks!

Like pierrerossel likes this

Thanks pierrerossel. It works like a charm.

Like # people like this

Hi, I am having trouble opening the editor

 

%localappdata%\Atlassian\SourceTree\git_local\mingw32\bin> ./git.exe config --edit --system
hint: Waiting for your editor to close the file... error: cannot spawn vi: No such file or directory
error: unable to start editor 'vi'

0 votes

Thanks, this just helped me. Had authentication error when trying to clone a remote repository and setting this as shown has fixed my issue. 

Thanks for the tip! 👏

2022 and the SourceTree OOB experience is just as broken still. Install it, run it, watch the credentials 'helper' pop up continually over and over until you manually edit the /etc/gitconfig file as above. Can't believe someone recommended this client to me :-)

I'm having trouble navigating here:

%localappdata%\Atlassian\SourceTree\git_local\mingw32\bin\

I cannot find 'git_local' in the SourceTree folder, only 'accounts.json'

Please confirm you're looking under Local and not Roaming AppData folders.

%localappdata%\Atlassian\SourceTree\git_local\mingw32\bin

Not

%appdata%\Atlassian\SourceTree

(which contains accounts.json)

Otherwise, check if you're using System Git (%ProgramFiles%\Git) rather than Embedded Git (%localappdata%\Atlassian\SourceTree\git_local\mingw32\bin).

Refer to this KB article:

https://confluence.atlassian.com/sourcetreekb/using-embedded-git-or-system-git-in-sourcetree-785323587.html

 

The powershell code wont work for me. I tried CMD but cant seem to close and save that file.

 

I can save that setting in that popup to "Always use..", but still nothing

 

THe person who thought it was nice to add PUFFY, can some drop that person from a bridge! WTF im so damn annoyed by that old crap software.

Like superkyle888 likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events