Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Problems when pushing


I'm using sourcetree with I'm trying to push changes to the main repository. When I do, it doesn't work and I have this error message:

Pushing to
POST git-receive-pack (1186 bytes)
remote: One of your commit messages is missing a valid issue key:        
remote:   0cb639f: Tried to solve issue 120 by deleting some quotation marks and added commas for the comment section.        
remote: For more information, see        
 = [up to date]      0.0.1 -> 0.0.1
 = [up to date]      0.0.2 -> 0.0.2
 = [up to date]      0.0.3 -> 0.0.3
 = [up to date]      0.0.4 -> 0.0.4
 = [up to date]      0.0.5 -> 0.0.5
 ! [remote rejected] develop -> develop (pre-receive hook declined)
error: failed to push some refs to ''


The problems seems to be with the of commit 0cb639f, since it doesn't include precisely the issue number. How can I add that? I'm not able to go back to this commit and change the message.

Thanks, Loic

1 answer

1 accepted

4 votes
Answer accepted
Ana Retamal
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Jan 23, 2019

Hi Loic,

I'd recommend doing fixing this in the command line. As that commit has not been pushed yet you can change the commit message doing a rebase, as explained here.

Once the issue number has been corrected, you should be able to push from Sourcetree with no issues.

Let us know how it goes!


Thanks! The problem was that it wasn't the last commit, but a precedent one blocking it. However, I found how to solve this, thanks the link you gave me. Best, L

Ana Retamal
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Jan 24, 2019

That's why a rebase was needed, otherwise and amend would have been sufficient :) 

Glad it's solved now!


Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events