Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Password Required to Push on SourceTree Edited

I set up an SSH key and I still get a password required message box whenever I try to push to Bitbucket from SourceTree. I am using MacOS Sierra 10.13.3.

2 answers

0 votes
Manju Atlassian Team Feb 20, 2018

Please check if the ssh-agent has your keys loaded. If not, please add them to the agent. 

Run below commands in terminal to do so,

To check if keys are loaded:

ssh-add -l

To add keys to agent:

ssh-add <path_to_key>

more like,

ssh-add ~/.ssh/id_rsa

Key in the passphrase used while generating the ssh key and you should be good to go.

I tried to check if keys are loaded and the response was that 

"The agent has no identities." How do I solve the problem?

Manju Atlassian Team Feb 20, 2018

Locate your ssh key on the disk. If you have used the default location, it should be located at ~/.ssh/ Use the file name for the key and add it to the ssh-agent with below command,

ssh-add ~/.ssh/<ssh_key_file_name>

The name of the file of the public key is id_rsa.pub but I get a syntax error with the following code:

ssh-add ~/.ssh/<id_rsa.pub>
Manju Atlassian Team Feb 20, 2018

You should do this,

ssh-add ~/.ssh/id_rsa

The command worked. It stated: "identity added".

What else do I do?

Manju Atlassian Team Feb 20, 2018

Assuming that you have added the key on Bitbucket, you should now be able to push to Bitbucket from Sourcetree without a password prompt. 

I am still asked for a password.

Manju Atlassian Team Feb 20, 2018

Can you please attach a screenshot of the account setup and the password prompt window?

Which account setup? Bitbucket?

For some reason, my MacOS Sierra 10.13.3 won't take screenshots.

I get the following message:

 

"Password Required

For user LaPlume on host bitbucket.org"

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,251 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you