Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,362,517
Community Members
 
Community Events
168
Community Groups

Password Required for user on host bitbucket.org

Hello everyone,

I have a question, and I am a complete noob at this so please bear with me.

 

I created a new repository on Bitbucket. I named it Remote Repo Test, Access Level: This is a private repository, Forking: Allow only Private Forks, Repository type: Git.

Then I clicked Create Repository

 

I then clicked Clone in Sourcetree. I hit the dialog box, open sourcetree app. 

 

From there I get the clone new box but I also get a system dialog box that says "Password Required For user jennaCreates on host bitbucket.org. I enter my Atlassian password because that is the password I use to log into bitbucket and nothing happens, the dialog box just gets stuck in a loop. I also tried using the terminal, (keep in mind I am a super noob with the terminal and I pasted the git clone followed by the address. It asked me to enter my password for bitbucket and I did. It looked like maybe it worked but I went back to sourcetree and my remote repository was not there.

 

Can anyone please help? I saw in other forums others having the same issue, but it did not work for me. My system information is below.

 

I am using Mac OS 10.13.2 and using Sourcetree 2.7.1 (159).

7 answers

I had a problem like this. When I tried to clone my repository with oAth I have been getting an errors with text like "incorrect username or password". Next time I selected different mode (the simple in Russian translate) authentification with username and password and got clone of my repository.

I have this problem only on MacOS. On PC with Windows 10 SourceTree work excellent.

Hi guys, maybe you could try clone the repo using different format of the url.

I didn't have HTTPS connection configured, only SSH, so when I was trying to paste "normal" url of the repo (http://bitbucket.org/...), I was getting the same annoying message about the password.

Try to use "Clone" button in your repository on Bitbucket, you'll get something like "git clone git@bitbucket.org(...).git". Copy this line without "git clone" and paste to SourceTree. Worked for me.

I have the same issue on Mac, Its the fifth error that I am facing connecting repository to cloud and each of them are a challenge. Why its so difficult to do this process. its now five hours that I am spending for this connection and still unsuccessful. I am trying to switch to Bitbucket but am a little worried after these problems 

yup same here, quite annoying. 

Any solution to this problem??

Don't know if this can help, I have version 4.1.5 and I encountered the same issue on a fresh installed Source Tree instance after I resetted my Macbook to factory settings.

I did a clone via the command line and had no issues. Then I came back to Source Tree and I could perform fetch, pull, etc.

Could it be that command line clone added `bitbucket.org` to the list of known hosts and this made Source Tree authentication work?

Please help,

 

SourceTree remains asking me the Password on host bitbucket.org

I think last friday I messed-up all when I tried to add a remote repository from another developer, and it looks the password stored in my mac is from this other account. How can I fix this?

hola@movildrive.com

0 votes
Ana Retamal Atlassian Team Mar 19, 2018

Hi Jenna! No worries, we're here to help :)

Can you confirm if it worked when you tried cloning your repo using the terminal? If you're not sure, you can take a screenshot of your terminal when you believe the process is finished and post it here. If it doesn't work when using your terminal, then there must be some issue with the authentication.

Regarding Sourcetree, I'd try connecting my Bitbucket account as explained at Connect your Bitbucket account. After that, can you try to clone again and see what happens?

Let us know!

Ana

Ok, I will try that in and let you know if it works. Thank you.

Hello Ana, Same issue. I connected my bitbucket account. Still has the problem. I didn't try cloning using terminal.

I have the same problem and I've tryied every solution in anothers Questions in this site, but nothing solves the problem.

Do you guys have thinked in fix it?

I tried connecting the account to SourceTree but it still remains on the same loop...

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events