Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,462,992
Community Members
 
Community Events
176
Community Groups

Not able to start feature branch by selecting commit id option

Hi,

I'm working on implementing Git Flow branching strategy in my company and for that I'm testing all possible options which is provided in SourceTree GitFlow.

Two problems I've faced till now:

1. I'm trying to start a new feature branch by selecting a specified commit with value but its failing with below error

sh.exe C:\Users\useraname\AppData\Local\Atlassian\SourceTree\gitflow_local\gitflow\git-flow feature start checkingfeaturebycommit d14c9a9a35d504958e3df6b42db5acfc8466bfd4
Fatal: Base 'd14c9a9a35d504958e3df6b42db5acfc8466bfd4' needs to be a branch. It does not exist and is required.
Completed with errors, see above.

 

2. what is meaning of second option while starting feature "Working copy parent"

because when I tried to start feature by selecting this option, it also failed with same error.

Please help me understand these and let me know if I'm doing anything wrong.

Thanks,

Imran

 

 

 

4 answers

5 votes
Mike Corsaro Atlassian Team Nov 20, 2017

Hello! This appears to be an issue with git-flow where it will not allow commit SHAs to be used when starting a new feature (I'd suggest that you file a bug here. If you'd like to start a new feature from a branch, then I'd recommend just typing the name of the branch into the "Specified commit" box.

  • "Working copy parent" refers to the 'parent' branch that you are currently working on. This will also not function due to the use of a commit SHA
  • "Latest development branch" refers to the branch that you've assigned to be "develop" when you initialized git-flow.

Btw, despite this workaround using branch name works if you want to branch from the last branch commit, probably the real solution to this problem is here (did not tried it yet): 
https://community.atlassian.com/t5/Sourcetree-questions/Is-git-flow-broken-in-Sourcetree-2-7-1/qaq-p/728759

It's the same problem with a release branch with a specific commit.

why is this funcion implemented in the workflow when it's not working?

I have the same problem, I need to create a release form a specific commit and it's failing, this functionality is imperative !

Hi everyone, even i faced same issue when trying to create a feature branch on working copy parent. Got the error fatal ...... as mentioned in issue statement. I am working on MAC.

I tried a workaround , may be it will be helpful for others too.

I created branch by clicking "Branch" button instead of Git flow.

And then gave it name like " feature/yourbranchname " , select working copy from radio options.

 

Hence this created feature branch on my working copy on current commit.

I have the same problem, I need to create a release form a specific commit and it's failing, this functionality is imperative !

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events