Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Not able to authenticate with bitbucket + Sourcetree + Mac

Related to this link, but I have tried everything there and I still cannot get Sourcetree to properly authenticate anything:

I have deleted the password file, I have removed the user in the Accounts tab, I have removed all the keychain passwords that were mentioned, uninstalled Sourcetree, rebooted my laptop more times than I can count, reinstalled Sourcetree, it prompts for my password, which I enter (and it is correct since I can login into the website with it), it accepts it, I try to do anything else, authentication is still failing.

Interestingly, I observe that when I add a user back using Sourcetree it is still pulling my username / password from someplace because it just auto adds it in.  Where this information is, I cannot fathom as I feel I have deleted everything I can.

This is using the Mac version trying to connect to a bitbucket repository.  Any help will be greatly appreciated!


1 answer

Seems I followed this path:

*) Removed all keychain access items

*) Removed the user from the accounts tab.

*) Uninstalled the application and removed the installer from downloads

*) Rebooted the laptop

*) Made sure the keychain access items were still gone for bit bucket

*) Downloaded the source tree installer and reinstalled

*) Added my user back to source tree under the Accounts tab using 

   *) OAuth

   *) SSH

Seems to have worked now, but I feel I did this same thing 3 times yesterday? :)  Do not want to try this again as I lost 1.5 days on this, but maybe this checklist will help someone else!  Let me know if it does!

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events