It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Mojave and GitHub not working Edited

Hi,

after switching to Mojave (10.14.6) I am not able to create something in my GitHub account.

I used SSH with Basic and Sourcetree generated a new SSH key.

I checked that my GitHub account has the PubKey.

I am able to list my private remote repositories from Sourcetree (3.2.1 (225)).

I even can clone my private repositories.

But as soon I want to push s.t. to the repository or create a remote repository it gives the cryptic error message:

message: Not Found

https://developer.github.com/v3/repos/#create

I added the key to the ssh-agent via ssh-add -K ~/.ssh/<mygithubaccount>-GitHub because it was not listed there (ssh-add -l).

But it didn't help.

After checking the authentication with

ssh -vT git@github.com

I get a success message with my GitHub account:

Hi <mygithubaccount>! You've successfully authenticated, but GitHub does not provide shell access.

Seems that a ssh connection is established (private repositories) but I have no permission to write into this GitHub account...

This way Sourcetree is unusable on Mac Mojave :-(

I did use it until now on Mac and Windows and all was running ok.

I activated the debugging mode in Sourcetree and watched the log but no entry.

Just network entries were generated but with no help.

Any help?

1 answer

0 votes

Hello Frank,

Thank you for including your detailed information and steps you’ve taken to troubleshoot the issue. Sourcetree does in fact work within Mojave, I have the feeling that something within your ssh trust has been broken during the upgrade. If you could please test Sourcetree on another profile to ensure it is working with GitHub and let us know the results?

We look forward to hearing back to help resolve your Sourcetree connection issues with GitHub.

Regards,
Stephen Sifers

Hi Stephen,

I set up Mojave in a fresh installation. 

During installation of ST the ssh keys were built. No other app that I installed needed the ssh. So the ST keys were the first ones.

I checked on Github for that public key and it was ok.

I tested this with different profiles on the MBP and with different profiles on a fresh Mojave on iMac.

Always the same result.

I can not imagine any error because the procedure should be simple.

Install Mojave, install ST, start ST, (create bitbucket login), create GitHub, enter credentials, save and it should run.

And indeed, I can clone from my private Github repositories after that procedure.

And as I decribed, manually ssh login is ok.

Just #create seems to crash with Github.

Edit: aaahhh, and not to forget: the same error occurred when I switched to HTTPS instead of ssh.

Like Stephen Sifers likes this

Hello Frank,

We’re going to need to create an issue to track this further. With this said, we’re going to need the crash log around the file the application crashes. The log we’re looking is the sroucetree.log which may be found at SourceTree logfile location. The Mac OS crash logs will also prove helpful if there is anything within them. Any other logs you may find around this time will also prove helpful.

Regards,
Stephen Sifers

Hi Stephen,

just to work with ST I already installed an older version (yes, I know the security risks :-( ). So I can not generate this special log file under my control.

But I found an older  log file from ST, perhaps this was created from the #create error...

But: Didn't find a possibility for attachment. The pure text was not possible to post...



Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,895 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you